summaryrefslogtreecommitdiff
path: root/dev-ruby/optionable
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ruby/optionable
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ruby/optionable')
-rw-r--r--dev-ruby/optionable/Manifest4
-rw-r--r--dev-ruby/optionable/metadata.xml11
-rw-r--r--dev-ruby/optionable/optionable-0.2.0.ebuild19
3 files changed, 34 insertions, 0 deletions
diff --git a/dev-ruby/optionable/Manifest b/dev-ruby/optionable/Manifest
new file mode 100644
index 000000000000..99305b6bfccd
--- /dev/null
+++ b/dev-ruby/optionable/Manifest
@@ -0,0 +1,4 @@
+DIST optionable-0.2.0.gem 9216 SHA256 878859afbf5f681c69bde1bee120f44c13ce570fc6d2430e29a517de8ad34b20 SHA512 4c633c83cd51fb2f1771f5f842cc8024d769f644d513a8d4486c7960d2bdda81be44746a7bb4604bb458cd58c3bbb5db28cb426d25cded6098263798f7daa465 WHIRLPOOL f7f4101fbc86ecea608014eee003fdc06832e911308137c6aeeee1519081bf7fc37ae0382eded3c41f4b01c65c13a615cff37c452e44710b995b8e2c35157740
+EBUILD optionable-0.2.0.ebuild 399 SHA256 1bf702057692d047ba3a36082d1c7aacb8cd694fb537eb99db21473137ddb76e SHA512 f94c1098e8663f495fbbe00b5cdeaf0889e04a5d04c0247ed6cd98ed45db6afabe0ab4dbb01dcc8845b7245969bc7f29499b88e08d68f31cf311c34ec4562a63 WHIRLPOOL 512916c36dfc37af6537d618792e5d899bc44c693078cc221eba14eb22435221c19107d222d0ccd7c0184633d03b2686064e3ee869f6bf99ae5b09c8e72e3148
+MISC ChangeLog 1361 SHA256 aad01ca110539a41e3671f0377aa8a9d67b53c73b466fac60e7879b3887d4a10 SHA512 b780e542d57f9a5ff4cdf1320822a8890ae98d2b770f28fc2dcad3115412bd2e7720801057bee55624411d3f0b6fb55cc0f8d9edca1fd00157c12b7702bbfd74 WHIRLPOOL e4fb830c7a1ad6aac240573aedd53e9e890be564af0109d6d8455441802843e87a87cde82994feca5c726674348414f4130db02acbd9b8c3c955be29d9c3abec
+MISC metadata.xml 343 SHA256 23046c8b5090fa62ddca1e09a6fcd832f1f14bb324136b7b602ab54d8c9fe3fc SHA512 0d809b55d6aa2e967ac7b85e0222365053e0876566ddb5554561289992da0945bd143f94f3ecf75e578a497ab4c341793a26f4815159ec4c0cb91439cd05cb01 WHIRLPOOL 3af0e8613df5f1d6661dac5fd17f8c2bde800531dea42578850d5b1d9670b701e89685d86ec0cbc2d06d6f949c8d60a75482a22734eacd5d6dfe306cac39274b
diff --git a/dev-ruby/optionable/metadata.xml b/dev-ruby/optionable/metadata.xml
new file mode 100644
index 000000000000..e7d5ab8ca00d
--- /dev/null
+++ b/dev-ruby/optionable/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">durran/optionable</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/optionable/optionable-0.2.0.ebuild b/dev-ruby/optionable/optionable-0.2.0.ebuild
new file mode 100644
index 000000000000..2c4a9de82cac
--- /dev/null
+++ b/dev-ruby/optionable/optionable-0.2.0.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby21 ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Robust options validation for Ruby methods"
+HOMEPAGE="https://github.com/durran/optionable"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""