summaryrefslogtreecommitdiff
path: root/dev-ruby/omniauth
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-08 15:03:58 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-08 15:03:58 +0100
commit814f4cf860e299a046b649eaee5463427984c09c (patch)
tree74c45f097899310e599dad6b8df5b63e0f085bc0 /dev-ruby/omniauth
parent7f0ccc917c7abe6223784c703d86cd14755691fb (diff)
gentoo resync : 08.07.2021
Diffstat (limited to 'dev-ruby/omniauth')
-rw-r--r--dev-ruby/omniauth/Manifest4
-rw-r--r--dev-ruby/omniauth/omniauth-1.9.1.ebuild4
-rw-r--r--dev-ruby/omniauth/omniauth-2.0.4.ebuild46
3 files changed, 51 insertions, 3 deletions
diff --git a/dev-ruby/omniauth/Manifest b/dev-ruby/omniauth/Manifest
index 590b1ec533b2..84134c84704b 100644
--- a/dev-ruby/omniauth/Manifest
+++ b/dev-ruby/omniauth/Manifest
@@ -1,3 +1,5 @@
DIST omniauth-1.9.1.tar.gz 26528 BLAKE2B da096ce924972c867ade4cde7e6ec90f5a7de41947f5d04ad092174baf3073ba6b235ff998551d9bbc7f6dfa2a4290eef1e1d962590591cf29f89395a554f3a9 SHA512 687ab9ad47d57d1cbe01fb7ed37754fecb3b75b7e62853070b5880ad6347a2834524a8d4042271ecd7f708ab35b7b5bd3203058ef03c3317f26f88a7639c2672
-EBUILD omniauth-1.9.1.ebuild 1193 BLAKE2B dca25cf4c30faa152389c8a90129d97f612171366fab6918338784b89c32586b95a47645c8b37d8e168a2fac57e963579ef1e82267a4e1981447a1d6e08b954c SHA512 17c389780b47c302f48dd1cd3dfc69daf3a2106b439147f71b9017e514e576f98656dceff996c776843a5475e72c6e6e57efb987633030c532014f9c505ca48a
+DIST omniauth-2.0.4.tar.gz 30951 BLAKE2B 6086a737e043ae37e6c7c4b1e4d597a08e6dc490c5d71f7847e9c5a8880bbbd1117470efbbe12e150bf238bf6e5413493712f1c09ae5e37f5d7b7676b6da023e SHA512 c92ce881388c9793e96354caee764cbabb28c69ca63b32f304693c4859eb8bf994e86b2cc9dbeb57993347e6f2787c43eab967c36730d5c47a3c4767d16847eb
+EBUILD omniauth-1.9.1.ebuild 1193 BLAKE2B f22832b72ee5a90f21dd03424417d79cfcf3ebbcd99a9e0aedc8d23137fb786b31d98504f04d489026c0162bf89199e3cc6836dbe8afa89c78744ec7045b54e7 SHA512 b39eca667bf83a141e1feade2f41e686dfb9ab37a9d9630e6f1ab62cf45632fa03e25076d86b368917275c1700896c3efa7e184ac50a151bb31418a67707a32e
+EBUILD omniauth-2.0.4.ebuild 1198 BLAKE2B 3bb4ae913e0bd7b9f6bff3c9c5a87dfea9f5d1dd26b3463fb3ef5e534516dc630bdc7cadf063750e5d9546e14b6b6d5652f8fbd13cdf3cadf53aeb6b6163e621 SHA512 de03904de0b34b0ff2f2e558ed2809610805fba843e89d0fbddc7f5a61e29f658a49c34418b1556cc08092e6999cfa277b7186295a4ffa68b8fdeb4e5a0bd201
MISC metadata.xml 343 BLAKE2B eca1c20d937a878552be8bffd3394dc6a5b472b87a88f1ef2a096fd2ee75fe4feb343990c8e021bcc1144b6257175e2f8119ee374b6b551ebf19bcfc7860dd9d SHA512 189a7a11a84b2fa108299499e9f867768246b34237b74029eba64a0895d5c95d39544e340c4340cf50644f602411dfad991ff460c0269f1956061641e3cba130
diff --git a/dev-ruby/omniauth/omniauth-1.9.1.ebuild b/dev-ruby/omniauth/omniauth-1.9.1.ebuild
index d58ecb6d1b6b..28d880e64b38 100644
--- a/dev-ruby/omniauth/omniauth-1.9.1.ebuild
+++ b/dev-ruby/omniauth/omniauth-1.9.1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-USE_RUBY="ruby24 ruby25 ruby26"
+USE_RUBY="ruby25 ruby26 ruby27"
RUBY_FAKEGEM_EXTRADOC="README.md"
RUBY_FAKEGEM_RECIPE_TEST="rspec3"
diff --git a/dev-ruby/omniauth/omniauth-2.0.4.ebuild b/dev-ruby/omniauth/omniauth-2.0.4.ebuild
new file mode 100644
index 000000000000..79e5a2b31ca8
--- /dev/null
+++ b/dev-ruby/omniauth/omniauth-2.0.4.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_DOCDIR="doc"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A generalized Rack framework for multiple-provider authentication"
+HOMEPAGE="https://github.com/intridea/omniauth"
+SRC_URI="https://github.com/intridea/omniauth/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="MIT"
+KEYWORDS="~amd64"
+SLOT="$(ver_cut 1)"
+IUSE=""
+
+ruby_add_rdepend "
+ =dev-ruby/rack-2*
+ dev-ruby/rack-protection
+ >=dev-ruby/hashie-3.4.6:*"
+ruby_add_bdepend "doc? ( dev-ruby/yard )
+ test? ( dev-ruby/rack-test )"
+
+all_ruby_prepare() {
+ sed -i -e '/[Bb]undler/d' \
+ Rakefile ${PN}.gemspec || die "sed failed"
+ sed -i -e '/RUBY_VERSION/,/^end/ s:^:#: ; /freeze/ s:^:#:' spec/helper.rb || die "sed failed"
+ # maruku fails, resorting to default markdown implementation
+ sed -i -e '/maruku/d' .yardopts || die "sed failed"
+
+ sed -i -e '/s.files/d' ${RUBY_FAKEGEM_GEMSPEC} || die
+}
+
+all_ruby_compile() {
+ all_fakegem_compile
+
+ if use doc ; then
+ yard || die "yard failed"
+ fi
+}