summaryrefslogtreecommitdiff
path: root/dev-ruby/octokit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-05 21:17:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-05 21:17:31 +0100
commitdc7cbdfa65fd814b3b9aa3c56257da201109e807 (patch)
treec85d72f6f31f21f178069c9d41d41a7c1ff4b362 /dev-ruby/octokit
parent0706fc6986773f4e4d391deff4ad5143c464ea4e (diff)
gentoo resync : 05.04.2019
Diffstat (limited to 'dev-ruby/octokit')
-rw-r--r--dev-ruby/octokit/Manifest2
-rw-r--r--dev-ruby/octokit/octokit-4.14.0.ebuild33
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-ruby/octokit/Manifest b/dev-ruby/octokit/Manifest
index 7ccdebfc5287..89160570b2ff 100644
--- a/dev-ruby/octokit/Manifest
+++ b/dev-ruby/octokit/Manifest
@@ -1,3 +1,5 @@
DIST octokit-4.13.0.tar.gz 3053006 BLAKE2B 7028cd8c14865a1b061a5ad95f103944b20827797e5f75dbbc8237ed91cb7c9fc79e9a9319dddd9dcee58d32071156e02c04f7d39c4073bad789cbc65887c2df SHA512 48716876e8c5d807e5ebfbd2236bc4b1558d0d1dfd5d3c4cd42b345e3c8164ea36176c23a23e2bb84078e5a6fdeba2b55c3ae8ec0a6451258fe683d84b007013
+DIST octokit-4.14.0.tar.gz 3068165 BLAKE2B e50efa246273422daf5aed8e619465886962d361d129a310974c21bbc683c7444ee99e3dc01c184497683d07a48d852c006ab56c6cd4bea8660f16e7ec5eee98 SHA512 2aff18492c0207b8c7ced23adf0e76260d2976331563e22f7a130445b19b816a00281a86b4161d6709025d058c848ef3f7d1a5c64323954f8c03a59be6f6b132
EBUILD octokit-4.13.0.ebuild 857 BLAKE2B 0b624e3b35dac39426790927ed1d0d61d46427032ac44d9f5b093c5d57647751437c6b4e60930cbbdc30d635ce54b9cd34558e5ab327f1429aaf11d98b14d49f SHA512 5efbb8254de4e3699c51684dfbeb4e4d12b0545f72b51828ec56f733f5ee402dd56acf78c4541283bda36a3640dcdc3846ce9a40e1320acf745b7635715bc391
+EBUILD octokit-4.14.0.ebuild 857 BLAKE2B 36ecd2d33e4ee586844b9fd3fc22b30c042c19794f36c94e3f8dabe6c171503939194153549d8d69637be03c58a887c38c58d94bd224269885728a0f9052a90a SHA512 0b8182c6cb06fffedf508a1cae21a36350ebcf6acba65fbc41f9ab2bfab1af042bd6f073ba9dc6ab0d032b999ec26ef9e26918b0ecd07679e2964a363a1a7719
MISC metadata.xml 344 BLAKE2B a2013bc4988a44c7d4b2e9dd6005d30390a7fdaf39f37a4adf8b539825b43f5d0eec457dae147b782f90f15d77fa5f485a6bada65be086f67b7350603945cf64 SHA512 3866d3979a8749d780367b56ae524d8f78286d2174602452ba272d26a4fb49cbbe8945183e4a64e70400b758fba4fc6bf88bcdf24908e474a378b628a1263457
diff --git a/dev-ruby/octokit/octokit-4.14.0.ebuild b/dev-ruby/octokit/octokit-4.14.0.ebuild
new file mode 100644
index 000000000000..e4f7af55045e
--- /dev/null
+++ b/dev-ruby/octokit/octokit-4.14.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_DOC="yard"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_EXTRADOC="README.md CONTRIBUTING.md"
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="Ruby toolkit for the Github API"
+HOMEPAGE="https://github.com/octokit/octokit.rb"
+SRC_URI="https://github.com/octokit/octokit.rb/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+RUBY_S=octokit.rb-${PV}
+
+ruby_add_rdepend ">=dev-ruby/sawyer-0.8.0"
+ruby_add_bdepend "test? ( dev-ruby/mime-types
+ >=dev-ruby/netrc-0.7.7
+ dev-ruby/vcr:3
+ dev-ruby/webmock:3 )"
+
+all_ruby_prepare() {
+ sed -i -e '/if RUBY_ENGINE/,/^end/ s:^:#: ; 1igem "webmock", "~>3.0"' spec/helper.rb || die
+}