summaryrefslogtreecommitdiff
path: root/dev-ruby/octokit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/octokit
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/octokit')
-rw-r--r--dev-ruby/octokit/Manifest3
-rw-r--r--dev-ruby/octokit/metadata.xml11
-rw-r--r--dev-ruby/octokit/octokit-4.7.0.ebuild33
3 files changed, 47 insertions, 0 deletions
diff --git a/dev-ruby/octokit/Manifest b/dev-ruby/octokit/Manifest
new file mode 100644
index 000000000000..4d1769936b56
--- /dev/null
+++ b/dev-ruby/octokit/Manifest
@@ -0,0 +1,3 @@
+DIST octokit-4.7.0.tar.gz 2926712 BLAKE2B 07224de4132ac97525f2a8da784c74a150328f7e7ba08de32485e3fc43231e1583ddf8c16b119c85baece2cba90321059c77c624e450e98dc03ce7c84be54719 SHA512 7a760f909e4756401ce7ecfb3dc8682ec2c630b7ca1639135e61912f8dac2a18974ced1fd5b2d75ee14d1fcc567a370781c159303d7789a9a3f4b756186e72c1
+EBUILD octokit-4.7.0.ebuild 860 BLAKE2B 03369a2a73b94fe8ac54db3922481b2cc6b801ef5cd96018fb7ecfe48f073a2935af9c93dad481d815e713e9ade2db5a1715c39c0e54c040be311e73729fcb5a SHA512 df6ff18d386049ffc81b6aaca3512d4374738cac3f4d8de0e9769d1c0ba0a10b88cc2b27d856e87376ba6e3b8fe4ab2b7c51787e1878102c33721220fa278a04
+MISC metadata.xml 344 BLAKE2B a2013bc4988a44c7d4b2e9dd6005d30390a7fdaf39f37a4adf8b539825b43f5d0eec457dae147b782f90f15d77fa5f485a6bada65be086f67b7350603945cf64 SHA512 3866d3979a8749d780367b56ae524d8f78286d2174602452ba272d26a4fb49cbbe8945183e4a64e70400b758fba4fc6bf88bcdf24908e474a378b628a1263457
diff --git a/dev-ruby/octokit/metadata.xml b/dev-ruby/octokit/metadata.xml
new file mode 100644
index 000000000000..fd61014adc35
--- /dev/null
+++ b/dev-ruby/octokit/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">octokit/octokit.rb</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/octokit/octokit-4.7.0.ebuild b/dev-ruby/octokit/octokit-4.7.0.ebuild
new file mode 100644
index 000000000000..6510b8100b28
--- /dev/null
+++ b/dev-ruby/octokit/octokit-4.7.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_RECIPE_DOC="yard"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_EXTRADOC="README.md CONTRIBUTING.md"
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="Ruby toolkit for the Github API"
+HOMEPAGE="https://github.com/octokit/octokit.rb"
+SRC_URI="https://github.com/octokit/octokit.rb/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm"
+IUSE=""
+
+RUBY_S=octokit.rb-${PV}
+
+ruby_add_rdepend ">=dev-ruby/sawyer-0.8.0"
+ruby_add_bdepend "test? ( dev-ruby/mime-types
+ >=dev-ruby/netrc-0.7.7
+ dev-ruby/vcr:2
+ >=dev-ruby/webmock-1.9:0 )"
+
+all_ruby_prepare() {
+ sed -i -e "1,10d" -e "/require 'vcr'/i\gem 'vcr', '~> 2.9.2'" spec/helper.rb || die
+}