summaryrefslogtreecommitdiff
path: root/dev-ruby/oauth
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-02-11 16:09:52 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-02-11 16:09:52 +0000
commitf78108598211053d41752a83e0345441bb9014ae (patch)
treedd2fc7ae0a1aea7bda4942ab0c453d1e55284b37 /dev-ruby/oauth
parentdc45b83b28fb83e9659492066e347b8dc60bc9e3 (diff)
gentoo resync : 11.02.2018
Diffstat (limited to 'dev-ruby/oauth')
-rw-r--r--dev-ruby/oauth/Manifest4
-rw-r--r--dev-ruby/oauth/oauth-0.5.1.ebuild44
-rw-r--r--dev-ruby/oauth/oauth-0.5.3.ebuild4
3 files changed, 3 insertions, 49 deletions
diff --git a/dev-ruby/oauth/Manifest b/dev-ruby/oauth/Manifest
index 7c56aede676c..c50f28190bfe 100644
--- a/dev-ruby/oauth/Manifest
+++ b/dev-ruby/oauth/Manifest
@@ -1,5 +1,3 @@
-DIST oauth-0.5.1.tar.gz 46675 BLAKE2B 4522326d48c9a8004819a82d23c9151ecb0b10a6f60ef57a521f8f1cf86fbfb4c3181f7a29b6f29407569da2acb6c1f5033e003a54db92586d5cd92f957d6214 SHA512 fe00e4455ab72edb38051e0c203f27b299b624cdc3ba031de9aea33c1429a54a364f066297dae86c22b723859ab8bd8854b02d344ec49a535c28b256e96593a6
DIST oauth-0.5.3.tar.gz 59355 BLAKE2B d676ca2aade85a43655ca95ff289b248c33197a06f58b5d998b834ec6750547c5b66d781f97b66b04584f6f6825d010434cb9a73cf5ec69b900a73f0dce1d8f0 SHA512 658a0b2c8b2eaa51981fd274c5058996309aa0a7098fad8221ca4074f51d996c17c5bdd8373da5e13b6cdc782b9d59769b705f2aa6ad724a2ebd14034ff92e9e
-EBUILD oauth-0.5.1.ebuild 1186 BLAKE2B 8547ed0aed4794659e6775900358e1e4be45643d870fbeb4cb20c5fd42e1d909619bcc18f44e0c41af8e002f454cf099b251528a58cc5d723266c2ad5b005a02 SHA512 48fa1a015715331d5b3d21745d0d3608d58dc10ef88db3d46c18b466cbb7e0b34d586d01e8db9d102930b21a582230a58cc9f0fddd9d26875addf0af82bd6903
-EBUILD oauth-0.5.3.ebuild 943 BLAKE2B 0f1bfa607dd0d68d9e6a6f0b7c7c92e04674c1d6258a3ae460b09cf5e617659816a582c3f3407e61ebdfa8e49bb0b295404bb44dcd0d1ee3faa098b635db8552 SHA512 473fd0a953460bc1d36330a75800b1732e61ecbdc092757440f8ebfba68473f0d93757b70a7c41a7da8c8af38612c0b7568d94314183a3277f30b020027c9a00
+EBUILD oauth-0.5.3.ebuild 948 BLAKE2B 0b6f8f6b0401a16311e49b44288856ffd38fc98db57b7889006e565a9344ad4ac0cc9252041d7376ff805b9f39c748a4156f69fd8857bf96407827911e6fba75 SHA512 a3597d261eec52aa7346676e55878a25f375244a099d6d693634b1ebaca80f297fe232257a61f7f5228ec72f6852db989f87e0ac4c82adb09d95997b123667b8
MISC metadata.xml 335 BLAKE2B 57f59b76960a57baa7a46f505fa812b1f3417ea7f026272eb513139014e245cf7f34c286a677b6b91e7bd293c28da283dca118e32f76338758bf4a2247c01a32 SHA512 a740b8de21545f432e6e1d4b72a588bd1332bca643f017d8cffa84ae76f6a3d4514e3734f24f80954b7691034411b46463581291ae405a1026b90d93d991cb96
diff --git a/dev-ruby/oauth/oauth-0.5.1.ebuild b/dev-ruby/oauth/oauth-0.5.1.ebuild
deleted file mode 100644
index 1b866d8157f6..000000000000
--- a/dev-ruby/oauth/oauth-0.5.1.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-USE_RUBY="ruby21 ruby22 ruby23"
-
-RUBY_FAKEGEM_TASK_DOC=""
-
-RUBY_FAKEGEM_EXTRADOC="HISTORY README.rdoc TODO"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A RubyGem for implementing both OAuth clients and servers"
-HOMEPAGE="https://github.com/oauth-xx/oauth-ruby"
-SRC_URI="https://github.com/oauth-xx/oauth-ruby/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-RUBY_S="${PN}-ruby-${PV}"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86-macos"
-IUSE=""
-
-ruby_add_bdepend "test? (
- dev-ruby/test-unit:2
- dev-ruby/mocha:1.0
- dev-ruby/webmock
- dev-ruby/rack )"
-
-all_ruby_prepare() {
- # Require a compatible version of mocha
- sed -i -e '1igem "mocha", "~> 1.0"' \
- -e '2i gem "test-unit"; require "test/unit"' \
- -e '/byebug/ s:^:#:' test/test_helper.rb || die
-
- # Remove tests that require Rails 2.3 since that is ruby18-only.
- rm -f test/test_action_controller_request_proxy.rb || die
-
- # Remove typhoeus tests since they require an old version.
- rm -f test/test_typhoeus_request_proxy.rb || die
-}
-
-each_ruby_test() {
- ${RUBY} -I.:lib -e 'Dir["test/**/test_*.rb"].each{|f| require f}' || die
-}
diff --git a/dev-ruby/oauth/oauth-0.5.3.ebuild b/dev-ruby/oauth/oauth-0.5.3.ebuild
index 59fae1c6f0a9..883027835fb1 100644
--- a/dev-ruby/oauth/oauth-0.5.3.ebuild
+++ b/dev-ruby/oauth/oauth-0.5.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -17,7 +17,7 @@ RUBY_S="${PN}-ruby-${PV}"
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~amd64 ~x86-macos"
+KEYWORDS="~amd64 ~x86 ~x86-macos"
IUSE=""
ruby_add_bdepend "test? (