summaryrefslogtreecommitdiff
path: root/dev-ruby/oauth
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-11-13 13:10:00 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-11-13 13:10:00 +0000
commite9d044d4b9b71200a96adfa280848858c0f468c9 (patch)
tree1bd8ef816043a8cd340f1d774e79553a1a7d31d8 /dev-ruby/oauth
parentfc2f1018fc323ef2c6572734a9b130427cba76a6 (diff)
gentoo resync : 13.11.2021
Diffstat (limited to 'dev-ruby/oauth')
-rw-r--r--dev-ruby/oauth/Manifest4
-rw-r--r--dev-ruby/oauth/oauth-0.5.7.ebuild39
-rw-r--r--dev-ruby/oauth/oauth-0.5.8.ebuild39
3 files changed, 82 insertions, 0 deletions
diff --git a/dev-ruby/oauth/Manifest b/dev-ruby/oauth/Manifest
index 72b6b4e9464f..6afb9b12978a 100644
--- a/dev-ruby/oauth/Manifest
+++ b/dev-ruby/oauth/Manifest
@@ -1,3 +1,7 @@
DIST oauth-0.5.6.tar.gz 60887 BLAKE2B 8dea7bc6b1a3c9d5befa5badbda105fed28004d6627624fedaf1572cc261421e3a8636019bb0a600a28fb6aa933d2b1be5faf613ae3062f7d50b314b86059b17 SHA512 dcb516b90d6cf0ff3f1071fa7bf1e1b30cd998c79205f9a6df001d5c04784ad23ecd430b4e04565a6351efcc780b552dfc38ea962d0a938c9e19a6e5bd3fe070
+DIST oauth-0.5.7.tar.gz 65889 BLAKE2B 71787b6a03156a25edbb006acd05f7aae789e9bc0fffa0afe9d3f0c55a2b991fa20527c493e9933891adc0e32571c1834f1a3f928e12f2a7b3159ebc09d29286 SHA512 4bc217123aaf74482ed118344c57b241b9efea172d872d670a860e8f236fac4ae1956826fcc786025164a5728c62edded8cb453f0051091c48bc87fe1f72f931
+DIST oauth-0.5.8.tar.gz 67852 BLAKE2B 7dc19a2f84f585fd517d677bf441c5964b45566ffea3cbd7612061db115a5570cf8315b4cbdd8788f9b0ff336b6eea91922f17c0ce17a4c626731282bd8203ca SHA512 3bf8298ea5bcffe1fe61ba894a5cfcb04a5814348154749e056ea18d975b00b10db7ed226f2187ffb9f414b755022bf32ff4bb2c02f1f429f6a9a7062032d82e
EBUILD oauth-0.5.6.ebuild 1053 BLAKE2B e7304763762ecd688764cea37c0bbea669caf19ef4e421b27d848b869dfd2b1bd54d1226410c70db6c48b333b41d3af174711277f5f9df0b22f6de866a89d56c SHA512 297239d72c4bb9873697365cd466efb856b2d999cbabe94025bea30c1b51365c0b027d7e46c669ce02333ae01cdb44ed9a11c65b633b9726b11380b130e946e2
+EBUILD oauth-0.5.7.ebuild 1049 BLAKE2B 909bdb4db7093ba89ea90a1285eb582716cbd3a6f440912b72295315d0b5e9b872a40f34e0311267c6174a593593b726bcf92ce9c226472d250126b02cb2cc6e SHA512 9b6611b830cbe269ab02ec6963fe7e064d77b6cf112f30c9e4cd154135c3037f2b8faf273d7441153c03a371382a89e2b11c803031f50249675173115c10597c
+EBUILD oauth-0.5.8.ebuild 1049 BLAKE2B 909bdb4db7093ba89ea90a1285eb582716cbd3a6f440912b72295315d0b5e9b872a40f34e0311267c6174a593593b726bcf92ce9c226472d250126b02cb2cc6e SHA512 9b6611b830cbe269ab02ec6963fe7e064d77b6cf112f30c9e4cd154135c3037f2b8faf273d7441153c03a371382a89e2b11c803031f50249675173115c10597c
MISC metadata.xml 336 BLAKE2B ab0fbd6793480301de481d3d1cfe9b26bfd24573f43d742c154fb4ddf4d0550663acd415dda46dbace5005085a40714fe3fdd9a84b147154c8ed3fdc47d59c02 SHA512 b99860f6b76b68cad2e0bde7a8c8d7156e4806dbed1f11f4579dfd8a89c372f7963d90b273a2ca3abbae82072aa91fba475b051b9dfaa7c557e4f36cbb5c85a6
diff --git a/dev-ruby/oauth/oauth-0.5.7.ebuild b/dev-ruby/oauth/oauth-0.5.7.ebuild
new file mode 100644
index 000000000000..cdb746579c6c
--- /dev/null
+++ b/dev-ruby/oauth/oauth-0.5.7.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md TODO"
+
+RUBY_FAKEGEM_GEMSPEC="oauth.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A RubyGem for implementing both OAuth clients and servers"
+HOMEPAGE="https://github.com/oauth-xx/oauth-ruby"
+SRC_URI="https://github.com/oauth-xx/oauth-ruby/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+RUBY_S="${PN}-ruby-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+ruby_add_bdepend "test? (
+ dev-ruby/bundler
+ dev-ruby/test-unit:2
+ dev-ruby/mocha:1.0
+ dev-ruby/webmock
+ dev-ruby/rack
+ dev-ruby/actionpack:6.0
+ dev-ruby/railties:6.0
+)"
+
+all_ruby_prepare() {
+ # Require a compatible version of mocha
+ sed -i -e '1igem "mocha", "~> 1.0"; gem "railties", "~>6.0.0" ; gem "actionpack", "~>6.0.0"' \
+ -e '2i gem "test-unit"; require "test/unit"' \
+ -e '/mocha/ s/mini_test/minitest/' \
+ -e '/\(byebug\|minitest_helpers\|simplecov\)/I s:^:#:' test/test_helper.rb || die
+}
diff --git a/dev-ruby/oauth/oauth-0.5.8.ebuild b/dev-ruby/oauth/oauth-0.5.8.ebuild
new file mode 100644
index 000000000000..cdb746579c6c
--- /dev/null
+++ b/dev-ruby/oauth/oauth-0.5.8.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md TODO"
+
+RUBY_FAKEGEM_GEMSPEC="oauth.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A RubyGem for implementing both OAuth clients and servers"
+HOMEPAGE="https://github.com/oauth-xx/oauth-ruby"
+SRC_URI="https://github.com/oauth-xx/oauth-ruby/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+RUBY_S="${PN}-ruby-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+ruby_add_bdepend "test? (
+ dev-ruby/bundler
+ dev-ruby/test-unit:2
+ dev-ruby/mocha:1.0
+ dev-ruby/webmock
+ dev-ruby/rack
+ dev-ruby/actionpack:6.0
+ dev-ruby/railties:6.0
+)"
+
+all_ruby_prepare() {
+ # Require a compatible version of mocha
+ sed -i -e '1igem "mocha", "~> 1.0"; gem "railties", "~>6.0.0" ; gem "actionpack", "~>6.0.0"' \
+ -e '2i gem "test-unit"; require "test/unit"' \
+ -e '/mocha/ s/mini_test/minitest/' \
+ -e '/\(byebug\|minitest_helpers\|simplecov\)/I s:^:#:' test/test_helper.rb || die
+}