summaryrefslogtreecommitdiff
path: root/dev-ruby/oauth
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/oauth
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/oauth')
-rw-r--r--dev-ruby/oauth/Manifest3
-rw-r--r--dev-ruby/oauth/metadata.xml11
-rw-r--r--dev-ruby/oauth/oauth-0.5.4.ebuild36
3 files changed, 50 insertions, 0 deletions
diff --git a/dev-ruby/oauth/Manifest b/dev-ruby/oauth/Manifest
new file mode 100644
index 000000000000..4d35ba21075a
--- /dev/null
+++ b/dev-ruby/oauth/Manifest
@@ -0,0 +1,3 @@
+DIST oauth-0.5.4.tar.gz 59141 BLAKE2B 1e588d411795b7c5b4ae5b7b3c9928b69aaa005bef858137759757e9f06d6de144408e4dba33d7fbf82a3f2586238a71b85b89c681f5d633453dfe0da954a2fb SHA512 f114f80255944934a276d0f9556ed37e4a0a72b221269cf7792f2c3a5a1504c5ec726fd5b7437b1102c648a6cf451a1c83de4689f53d30ea8c6a1d62662de535
+EBUILD oauth-0.5.4.ebuild 953 BLAKE2B 158e6f759ab55eac9a1150e62fa991451d6f021c43d9588f4e8df882434143f5e415bf39a8c2f1743fefef181718569ccc6d012c7e5fa265d3ab707a7dc68925 SHA512 a6550c10e2f9d95541f330da186ad6ca2f99d979f3e43ef6c7328711963b97d1482f80064d84790774e90fdea6306c0dfd39e8f6719bf7ea72b5e9dabcb6958b
+MISC metadata.xml 335 BLAKE2B 57f59b76960a57baa7a46f505fa812b1f3417ea7f026272eb513139014e245cf7f34c286a677b6b91e7bd293c28da283dca118e32f76338758bf4a2247c01a32 SHA512 a740b8de21545f432e6e1d4b72a588bd1332bca643f017d8cffa84ae76f6a3d4514e3734f24f80954b7691034411b46463581291ae405a1026b90d93d991cb96
diff --git a/dev-ruby/oauth/metadata.xml b/dev-ruby/oauth/metadata.xml
new file mode 100644
index 000000000000..f20a3a8fdaf9
--- /dev/null
+++ b/dev-ruby/oauth/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">oauth-xx/oauth-ruby</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/oauth/oauth-0.5.4.ebuild b/dev-ruby/oauth/oauth-0.5.4.ebuild
new file mode 100644
index 000000000000..1b883606f567
--- /dev/null
+++ b/dev-ruby/oauth/oauth-0.5.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+RUBY_FAKEGEM_EXTRADOC="HISTORY README.rdoc TODO"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A RubyGem for implementing both OAuth clients and servers"
+HOMEPAGE="https://github.com/oauth-xx/oauth-ruby"
+SRC_URI="https://github.com/oauth-xx/oauth-ruby/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+RUBY_S="${PN}-ruby-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-macos"
+IUSE=""
+
+ruby_add_bdepend "test? (
+ dev-ruby/test-unit:2
+ dev-ruby/mocha:1.0
+ dev-ruby/webmock
+ dev-ruby/rack
+ dev-ruby/actionpack:5.1
+)"
+
+all_ruby_prepare() {
+ # Require a compatible version of mocha
+ sed -i -e '1igem "mocha", "~> 1.0"; gem "actionpack", "~>5.1.0"' \
+ -e '2i gem "test-unit"; require "test/unit"' \
+ -e '/\(byebug\|minitest_helpers\|simplecov\)/I s:^:#:' test/test_helper.rb || die
+}