summaryrefslogtreecommitdiff
path: root/dev-ruby/oauth2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-20 08:41:03 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-20 08:41:03 +0100
commitc915adf64c1415679bfe6b55c95348db2f89202e (patch)
tree4d14cad3390132f7c20f71d055ce4672c160a0c0 /dev-ruby/oauth2
parent2d5fd1dd4910d46f935776f1f6f475de11367ef2 (diff)
gentoo auto-resync : 20:07:2022 - 08:41:03
Diffstat (limited to 'dev-ruby/oauth2')
-rw-r--r--dev-ruby/oauth2/Manifest2
-rw-r--r--dev-ruby/oauth2/oauth2-1.4.10.ebuild58
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-ruby/oauth2/Manifest b/dev-ruby/oauth2/Manifest
index 3e6758d84d26..0f991820f1f0 100644
--- a/dev-ruby/oauth2/Manifest
+++ b/dev-ruby/oauth2/Manifest
@@ -1,3 +1,5 @@
+DIST oauth2-1.4.10.tar.gz 65553 BLAKE2B 4b147a97536ae04b81ca5bc41117bc31c577aae9b7dc1f4f34830d3cd7b7013098e90ae83997c4917ca25e858b8738398eb708bfee954882359ed14b8e810172 SHA512 cee9e1f890f66252451cc22ab7135dda60c73bb200f2f1659a450b09dccc0a219982625ec45866dc9153669a4d35fb543fb6de497bfa83522b99c66e9c8b9d9b
DIST oauth2-1.4.7.tar.gz 32341 BLAKE2B f3db3ff7ebcf7bc0958a564fdb0812c1bfb613148c5a16655f276fda4d6dac7769196305d854ee0fc3f8b4b53a93b4ae504b348029e1b363bcb704293887347a SHA512 4a43b3f75e827e9a12a74a6fe13a29b141c0d5bcb6a0d5c86dc8d8726f650a9fd5250ecc2c31cee5e985f0cb50e02f828d27fd07577bcac4dfc8ff4e009bd710
+EBUILD oauth2-1.4.10.ebuild 1503 BLAKE2B b5d936a50bb5e1c89d63d7c516ff2db038117e45ae47af00cd0077599554a79cfa0b1aec31089f1ec192610eac2df06d87f1fe071d0e2a4a736650e8ec4d62cd SHA512 cf6400624f752b59b59a73f9cfe2670ba99123b64cc153291d59a0cd2ad814f181b4a6a6a9ad938097b438029c8c2465a8e33a3a4331dda11c94fa84bf68dbdb
EBUILD oauth2-1.4.7.ebuild 1478 BLAKE2B 5dd9591470cc825729a00b24de2332d27d4baaab0a78525187ac89d5895a80b7908e3b0fc485cb16d7f7673f8c4613780b5c72eddef1de1d93e99759cf717a37 SHA512 b22a376f34809b148fbfe899adcb65f8ee1544f8abd227eff9937fd05ba824a4f66ea1199515f86976bf4e6ba591e0571b4aed972e4b29c2ae961debc3787edd
MISC metadata.xml 342 BLAKE2B 14d2af934a4327d3d6c1c5236c0b5a0436c91cc3988d6957188171153c60a0f40b6dec75cb5acac49aa60518f89cc5bdb00e92021ca99249903f937df51f1b23 SHA512 cc8c7abab8d16e0ef97ec14f58bfc5941e161b2676950aaa45912812d53e523a54570407bcb2e9cd2527a0c6acca8f348422efdde66402c162e8a04dcfaabb8f
diff --git a/dev-ruby/oauth2/oauth2-1.4.10.ebuild b/dev-ruby/oauth2/oauth2-1.4.10.ebuild
new file mode 100644
index 000000000000..c95700fee32c
--- /dev/null
+++ b/dev-ruby/oauth2/oauth2-1.4.10.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby27 ruby30"
+
+RUBY_FAKEGEM_TASK_TEST="none"
+
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="oauth2.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Wrapper for the OAuth 2.0 protocol with a similar style to the OAuth gem"
+HOMEPAGE="https://github.com/oauth-xx/oauth2"
+SRC_URI="https://github.com/oauth-xx/oauth2/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend "
+ || ( dev-ruby/faraday:2 dev-ruby/faraday:1 >=dev-ruby/faraday-0.17.3:0 )
+ dev-ruby/jwt:2
+ >=dev-ruby/multi_json-1.3 =dev-ruby/multi_json-1*
+ >=dev-ruby/multi_xml-0.5:0
+ >=dev-ruby/rack-1.2:* <dev-ruby/rack-3:*"
+ruby_add_bdepend "test? (
+ >=dev-ruby/addressable-2.3
+ >=dev-ruby/rexml-3.2:3
+ dev-ruby/rspec:3
+ dev-ruby/rspec-pending_for
+ dev-ruby/rspec-stubbed_env
+)"
+
+all_ruby_prepare() {
+ sed \
+ -e '/silent/I s:^:#:' \
+ -e '1irequire "uri"' \
+ -e '/require.*oauth2/arequire "oauth2/version"' \
+ -i spec/helper.rb || die
+
+ sed -i -e '/yardstick/,/^end/ s:^:#:' \
+ -e '/bundler/I s:^:#:' Rakefile || die
+
+ # Avoid spec that is too fragile in relation to ENV
+ sed -i -e '/outputs to $stdout when OAUTH_DEBUG=true/a skip "fragile ENV stubbing"' spec/oauth2/client_spec.rb || die
+
+ sed -i -e 's/git ls-files -z/find * -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
+}
+
+each_ruby_test() {
+ CI=true ${RUBY} -S rspec-3 spec || die
+}