summaryrefslogtreecommitdiff
path: root/dev-ruby/oauth2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-ruby/oauth2
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/oauth2')
-rw-r--r--dev-ruby/oauth2/Manifest3
-rw-r--r--dev-ruby/oauth2/metadata.xml11
-rw-r--r--dev-ruby/oauth2/oauth2-1.4.0.ebuild42
3 files changed, 0 insertions, 56 deletions
diff --git a/dev-ruby/oauth2/Manifest b/dev-ruby/oauth2/Manifest
deleted file mode 100644
index b8d200a42195..000000000000
--- a/dev-ruby/oauth2/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-DIST oauth2-1.4.0.tar.gz 21299 BLAKE2B 1fe4640b374450279e556477c23972030d3aecac4c96e9174e57458deaccfbfa012e3bb66fe3db5e845a4004b91b763dab6f68b885ed7c1ddb2710cda29a8486 SHA512 2db67cba2403be8ea5d6f88f9818f295c29c08201f8ea5876c55cffe2fa926be465a11061654adffd77d13da9c7e56353ece7e4595cd9501acdcfeb58573b300
-EBUILD oauth2-1.4.0.ebuild 1113 BLAKE2B ef45c62600507cff11b8240c3dba97ce041eeaf419f902a4727cbb74406fb45013fd230d391572e95d926f457d42a9b0c2f809b828bab081302f314ba241c8da SHA512 eb64a82c52fb1df3bbd4ff98a0147a06339119f57540cb62514faad47a28963e79fa37941b668f5f353b6c5461c02e0a827044edec19c471d6f8b1c1c032c255
-MISC metadata.xml 341 BLAKE2B e2896d1d266992c01ed373b489cf71b9c4a7a5f57a2af37899ff63793dad41b9213eee0fd94f269735f630815819f0a08e51e8739b89a7e251b60c2f6894e26c SHA512 33c5be74161557ae3e5888730256536cd02baac6c26913add84d8ce90854c4a3bb57c31fec1287bf560268c681ea3acf2119f2fea3162dd07e3962ee34d74f9e
diff --git a/dev-ruby/oauth2/metadata.xml b/dev-ruby/oauth2/metadata.xml
deleted file mode 100644
index 6a31450fb065..000000000000
--- a/dev-ruby/oauth2/metadata.xml
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>ruby@gentoo.org</email>
- <name>Gentoo Ruby Project</name>
- </maintainer>
- <upstream>
- <remote-id type="github">intridea/oauth2</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-ruby/oauth2/oauth2-1.4.0.ebuild b/dev-ruby/oauth2/oauth2-1.4.0.ebuild
deleted file mode 100644
index 9e36d65fce45..000000000000
--- a/dev-ruby/oauth2/oauth2-1.4.0.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-USE_RUBY="ruby22 ruby23 ruby24"
-
-RUBY_FAKEGEM_TASK_TEST="none"
-RUBY_FAKEGEM_TASK_DOC="doc:rdoc"
-
-RUBY_FAKEGEM_DOCDIR="rdoc"
-RUBY_FAKEGEM_EXTRADOC="README.md"
-
-inherit ruby-fakegem eutils
-
-DESCRIPTION="Wrapper for the OAuth 2.0 protocol with a similar style to the OAuth gem"
-HOMEPAGE="https://github.com/intridea/oauth2"
-SRC_URI="https://github.com/intridea/oauth2/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-IUSE=""
-
-ruby_add_rdepend ">=dev-ruby/faraday-0.8 <dev-ruby/faraday-0.13
- >=dev-ruby/jwt-1.0 =dev-ruby/jwt-1*
- >=dev-ruby/multi_json-1.3 =dev-ruby/multi_json-1*
- >=dev-ruby/multi_xml-0.5:0
- >=dev-ruby/rack-1.2:* <dev-ruby/rack-3:*"
-ruby_add_bdepend "test? ( dev-ruby/rspec:3 )"
-
-all_ruby_prepare() {
- sed -i -e '/simplecov/,/^ end/ s:^:#:' \
- -e '1irequire "uri"' spec/helper.rb || die
-
- sed -i -e '/yardstick/,/^end/ s:^:#:' \
- -e '/bundler/I s:^:#:' Rakefile || die
-}
-
-each_ruby_test() {
- CI=true ${RUBY} -S rspec-3 spec || die
-}