summaryrefslogtreecommitdiff
path: root/dev-ruby/nio4r/nio4r-2.7.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-01 11:06:48 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-01 11:06:48 +0000
commit511da2e8215301136bf13531af2329e9703addaf (patch)
treee5b21768118114c1882a1f772d0565fb3ba1801a /dev-ruby/nio4r/nio4r-2.7.0.ebuild
parentd095cf23cccb27f0f047472717fdf96bf857110d (diff)
gentoo auto-resync : 01:12:2023 - 11:06:48
Diffstat (limited to 'dev-ruby/nio4r/nio4r-2.7.0.ebuild')
-rw-r--r--dev-ruby/nio4r/nio4r-2.7.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ruby/nio4r/nio4r-2.7.0.ebuild b/dev-ruby/nio4r/nio4r-2.7.0.ebuild
new file mode 100644
index 000000000000..381b1a8e8790
--- /dev/null
+++ b/dev-ruby/nio4r/nio4r-2.7.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby31 ruby32"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_RECIPE_DOC=""
+RUBY_FAKEGEM_EXTRADOC="changes.md readme.md"
+
+RUBY_FAKEGEM_EXTENSIONS=(ext/nio4r/extconf.rb)
+
+inherit ruby-fakegem
+
+DESCRIPTION="A high performance selector API for monitoring IO objects"
+HOMEPAGE="https://github.com/socketry/nio4r"
+
+LICENSE="MIT || ( BSD GPL-2 )"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86 ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE=""
+
+# Note that nio4r bundles a patched copy of libev, and without these
+# patches the tests fail: https://github.com/celluloid/nio4r/issues/15
+
+all_ruby_prepare() {
+ sed -i -e '/[Bb]undler/d' spec/spec_helper.rb || die
+ sed -e '/extension/ s:^:#:' -i Rakefile || die
+}