summaryrefslogtreecommitdiff
path: root/dev-ruby/net-http-pipeline
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
commit2771f79232c273bc2a57d23bf335dd81ccf6af28 (patch)
treec8af0fd04194aed03cf067d44e53c7edd3e9ab84 /dev-ruby/net-http-pipeline
parente9d044d4b9b71200a96adfa280848858c0f468c9 (diff)
gentoo resync : 05.12.2021
Diffstat (limited to 'dev-ruby/net-http-pipeline')
-rw-r--r--dev-ruby/net-http-pipeline/Manifest2
-rw-r--r--dev-ruby/net-http-pipeline/net-http-pipeline-1.0.1-r1.ebuild (renamed from dev-ruby/net-http-pipeline/net-http-pipeline-1.0.1.ebuild)13
2 files changed, 8 insertions, 7 deletions
diff --git a/dev-ruby/net-http-pipeline/Manifest b/dev-ruby/net-http-pipeline/Manifest
index 23e1c0c86b86..c988fc0a4948 100644
--- a/dev-ruby/net-http-pipeline/Manifest
+++ b/dev-ruby/net-http-pipeline/Manifest
@@ -1,4 +1,4 @@
AUX net-http-pipeline-accept-encoding.patch 654 BLAKE2B 11d1ecba6b2895ba4c3ae7408ef0bc3bbd5266885ab519090c172ff27c8dbb4e9adc2c90d8a03ea24e1e68043431e26236c9a1c6f939ad5f693815b2069e0183 SHA512 43c6382f01538faaedc38047d6099d26c6d91805c45eddd043fba0e98b4331fa42a2826ea8a3216ddd5ab047b37e8a7ce1ba4c52b9ed5c0c645a5483d2cd1931
DIST net-http-pipeline-1.0.1.gem 12800 BLAKE2B ed36d871544ec203ba6d72e864aca4ecfd6e975eb5d2d29a0c1f785ba7422734824535c2a30e36d1f031c2863ac4036f103d94eeeae00a8f6905354020d713e4 SHA512 1377c20038176f6c246a7d4adbce2c6972970d730902f9faefc31b2f6446f4237603f45f0f59de70eb9545e3c1e150fe6e63cf350551203166611bef7845f4e2
-EBUILD net-http-pipeline-1.0.1.ebuild 568 BLAKE2B aa364e00824a1da63255e5c6396be9fadd5524c6722148c232af03eb9e9958d3e3756ce327e638f0d837f114015418ee699fa95105af86a54992a51dc28f993d SHA512 8d7738241f61937e0ebe8c1f3b58d6fd4c64e4f035911e549caeabbf6aa7418689d88c4984f03aab522b5a7d11b5028cc50f104f89497d6577aa1f0b637832ea
+EBUILD net-http-pipeline-1.0.1-r1.ebuild 562 BLAKE2B 42c63c9bf14ee6927d88e9b139ca030d7e157eb3d1ba960d2ddb65985e56994c4624b2a1e01a4e3253ccf54207f6083602ac21d86c8d49ec161a5c7d89726e7b SHA512 8422a7baf4dba304487c1caed64780106478142321bdffd1f654f6362de012ba9412b5c22da103e6e48ab11379960585486e518a339a4967815d6e5f90efa2af
MISC metadata.xml 342 BLAKE2B bf3b5037df2144653caccd6c5cbeed381d412694dbbe7675fe39b45c509dd456ada975dd1c9c4af03e1ac9dcaba65f8a1cdaf039fb027bec5cdc06bed26acbef SHA512 5266c5d3be35c768b0a3a9631248a896f8e04b6d3067609c388c87fe643cc9ccdaea900832fc7772d4890196d5beb583976066434ac07ba0da0da9d9ae53348b
diff --git a/dev-ruby/net-http-pipeline/net-http-pipeline-1.0.1.ebuild b/dev-ruby/net-http-pipeline/net-http-pipeline-1.0.1-r1.ebuild
index 62b07e328b02..a4b32a23797d 100644
--- a/dev-ruby/net-http-pipeline/net-http-pipeline-1.0.1.ebuild
+++ b/dev-ruby/net-http-pipeline/net-http-pipeline-1.0.1-r1.ebuild
@@ -1,9 +1,8 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-USE_RUBY="ruby24 ruby25 ruby26 ruby27"
-RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30"
inherit ruby-fakegem
@@ -15,12 +14,14 @@ SLOT="1"
KEYWORDS="~amd64"
IUSE=""
-RUBY_PATCHES=( ${PN}-accept-encoding.patch )
-
ruby_add_bdepend "
test? ( dev-ruby/minitest )
"
+all_ruby_prepare() {
+ eapply -p0 "${FILESDIR}/${PN}-accept-encoding.patch"
+}
+
each_ruby_test() {
${RUBY} -Ilib:. -e 'Dir["test/test_*.rb"].each{|f| require f}' || die
}