summaryrefslogtreecommitdiff
path: root/dev-ruby/net-http-pipeline
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-ruby/net-http-pipeline
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/net-http-pipeline')
-rw-r--r--dev-ruby/net-http-pipeline/Manifest4
-rw-r--r--dev-ruby/net-http-pipeline/files/net-http-pipeline-accept-encoding.patch18
-rw-r--r--dev-ruby/net-http-pipeline/metadata.xml11
-rw-r--r--dev-ruby/net-http-pipeline/net-http-pipeline-1.0.1.ebuild23
4 files changed, 0 insertions, 56 deletions
diff --git a/dev-ruby/net-http-pipeline/Manifest b/dev-ruby/net-http-pipeline/Manifest
deleted file mode 100644
index fdae44f9cd95..000000000000
--- a/dev-ruby/net-http-pipeline/Manifest
+++ /dev/null
@@ -1,4 +0,0 @@
-AUX net-http-pipeline-accept-encoding.patch 654 BLAKE2B 11d1ecba6b2895ba4c3ae7408ef0bc3bbd5266885ab519090c172ff27c8dbb4e9adc2c90d8a03ea24e1e68043431e26236c9a1c6f939ad5f693815b2069e0183 SHA512 43c6382f01538faaedc38047d6099d26c6d91805c45eddd043fba0e98b4331fa42a2826ea8a3216ddd5ab047b37e8a7ce1ba4c52b9ed5c0c645a5483d2cd1931
-DIST net-http-pipeline-1.0.1.gem 12800 BLAKE2B ed36d871544ec203ba6d72e864aca4ecfd6e975eb5d2d29a0c1f785ba7422734824535c2a30e36d1f031c2863ac4036f103d94eeeae00a8f6905354020d713e4 SHA512 1377c20038176f6c246a7d4adbce2c6972970d730902f9faefc31b2f6446f4237603f45f0f59de70eb9545e3c1e150fe6e63cf350551203166611bef7845f4e2
-EBUILD net-http-pipeline-1.0.1.ebuild 492 BLAKE2B 53235fce1ee412819b3a4f095c642b79313ffef0f3f962749302134a77ee4382abe393c78e11811b70ac43f2443abddd44983bf59eeac6ef96086fd2e32b16b1 SHA512 6c029d376538e911e02d866200416a07311b26e74528bf557b76ad247a9dc156a66a71cab317e86374faa079dbed908dc3d2c3a83350cc3de73240e5dec1f8c4
-MISC metadata.xml 341 BLAKE2B decbae5c640bf76dcbee55de227dae7b7cbce0069e7200bf535a7406cc23b01c9d3965aeea69b6c30a3e40efd41b76e411e42c3d2d0c7b8619a08f9d50258bdf SHA512 4c7d03fb0f0d3fd52fae9413a204cab1aeb6e1975fc124c54faa1e3905bc15c6740207c3234747a27153700a9b4fd9e32f5e994248c1f540aef336cefa4c594e
diff --git a/dev-ruby/net-http-pipeline/files/net-http-pipeline-accept-encoding.patch b/dev-ruby/net-http-pipeline/files/net-http-pipeline-accept-encoding.patch
deleted file mode 100644
index 3adfdf28afdc..000000000000
--- a/dev-ruby/net-http-pipeline/files/net-http-pipeline-accept-encoding.patch
+++ /dev/null
@@ -1,18 +0,0 @@
---- test/test_net_http_pipeline.rb.old 2016-11-17 07:58:57.284997283 +0100
-+++ test/test_net_http_pipeline.rb 2016-11-17 07:58:50.345168508 +0100
-@@ -96,6 +96,7 @@
- def http_get
- get = []
- get << 'GET / HTTP/1.1'
-+ get << 'Accept-Encoding: gzip;q=1.0,deflate;q=0.6,identity;q=0.3'
- get << 'Accept: */*'
- get << 'User-Agent: Ruby' if RUBY_VERSION > '1.9'
- get.push nil, nil
-@@ -106,6 +107,7 @@
- def http_post
- get = []
- get << 'POST / HTTP/1.1'
-+ get << 'Accept-Encoding: gzip;q=1.0,deflate;q=0.6,identity;q=0.3'
- get << 'Accept: */*'
- get << 'User-Agent: Ruby' if RUBY_VERSION > '1.9'
- get.push nil, nil
diff --git a/dev-ruby/net-http-pipeline/metadata.xml b/dev-ruby/net-http-pipeline/metadata.xml
deleted file mode 100644
index 10bd8f038881..000000000000
--- a/dev-ruby/net-http-pipeline/metadata.xml
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>ruby@gentoo.org</email>
- <name>Gentoo Ruby Project</name>
- </maintainer>
- <upstream>
- <remote-id type="github">drbrain/net-http-pipeline</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-ruby/net-http-pipeline/net-http-pipeline-1.0.1.ebuild b/dev-ruby/net-http-pipeline/net-http-pipeline-1.0.1.ebuild
deleted file mode 100644
index a8ecd68283ff..000000000000
--- a/dev-ruby/net-http-pipeline/net-http-pipeline-1.0.1.ebuild
+++ /dev/null
@@ -1,23 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-USE_RUBY="ruby22 ruby23 ruby24 ruby25"
-RUBY_FAKEGEM_RECIPE_DOC="rdoc"
-
-inherit ruby-fakegem
-
-DESCRIPTION="An HTTP/1.1 pipelining implementation atop Net::HTTP"
-HOMEPAGE="http://docs.seattlerb.org/net-http-pipeline/"
-
-LICENSE="MIT"
-SLOT="1"
-KEYWORDS="~amd64"
-IUSE=""
-
-RUBY_PATCHES=( ${PN}-accept-encoding.patch )
-
-ruby_add_bdepend "
- dev-ruby/hoe
- test? ( dev-ruby/minitest )
-"