summaryrefslogtreecommitdiff
path: root/dev-ruby/net-http-persistent
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-12-06 02:07:39 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-12-06 02:07:39 +0000
commitd285f0ab4ab38d4ea1cd0757a465db5f06764e06 (patch)
tree1fec673dcd26669902404a2986868912c5b41860 /dev-ruby/net-http-persistent
parenta6764d56b1c85c8272783500983011c143c72d80 (diff)
gentoo auto-resync : 06:12:2024 - 02:07:38
Diffstat (limited to 'dev-ruby/net-http-persistent')
-rw-r--r--dev-ruby/net-http-persistent/Manifest2
-rw-r--r--dev-ruby/net-http-persistent/net-http-persistent-4.0.5.ebuild33
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-ruby/net-http-persistent/Manifest b/dev-ruby/net-http-persistent/Manifest
index 376cbd5cca1f..a15d6d1d6941 100644
--- a/dev-ruby/net-http-persistent/Manifest
+++ b/dev-ruby/net-http-persistent/Manifest
@@ -1,5 +1,7 @@
DIST net-http-persistent-4.0.2.tar.gz 23779 BLAKE2B 7ea0140ed9baf97f05f13816ddd836cc874a1861a0ca4d84d98fd8d5665163e96d74c6eef602088a12577addda8fad5c2194c7f679c59917255979c5618c1c8d SHA512 4ef028245092a15f5e017ed6f2723cb82a2ed1fdbcb55217e5807068a40601151c29f929c95ffb5bdaae12fe34dca6658e674e282be42e7b0909c0ff2ea984fd
DIST net-http-persistent-4.0.4.tar.gz 24093 BLAKE2B 9470b3638dd5c4fcf5af93c7341c73e10c7e70a4a86e20e6f425a3449fcb0b5950adb4579cb12926e64556f03eaf3c3aaf3969694dd8bbc82d6d9dc59077c4a7 SHA512 43e51d6803d381af6a203508484c7bd39356d277818541fd192c0c539d4ec9e2088414b199f99b174def59e1818b9bf34d1d205d4137c9529fc7409d6813a986
+DIST net-http-persistent-4.0.5.tar.gz 24367 BLAKE2B 724f72ed14198493c1b044157cb233010bab470be6915998eb19c32ced5f701e86f2534fefea088d3f46ea0acd4b07c1c5e3b8e6d191a006a97d012a4b6adca7 SHA512 79aea45a34631935de65d21db2b7f8832f60a107e70d40cd6d52b4a0fe5c4790222c8aa673b677b4c9a5c58e5d1718c95c81a33866b35c390d49d41854361d05
EBUILD net-http-persistent-4.0.2.ebuild 1091 BLAKE2B eb8f0c9283be2729bcc15630bc95f666f337e8128f9e988b74ebe1bd970c9d2a67e5563f3ff47aaaa00c6113be5a3f09b897e6403c12168bf5ef431656b355d4 SHA512 9800d731071b75152be570805e11f92fd5f80b4291305d89315d212898792983610fee9e3df3dee1d9152621e0066f9fe6e6e22aec535f110bb9ddfdfad0fef0
EBUILD net-http-persistent-4.0.4.ebuild 1091 BLAKE2B 10a8647e556e53436cb709766f207c1717db91d71fba4bd44188c8cc1b45f3523f2ec3b8c212e47cc57e346da841b5dd923e3cde8523b3410ed32dd8deba7bdf SHA512 49ab894fdd8b848538b1ad163d1677a1669ef1cfde022cf4a23a5fb7df50d884a0379776ff9cbff58eb3156b72202b5fc425484bf249c03e24df919c194033d3
+EBUILD net-http-persistent-4.0.5.ebuild 1093 BLAKE2B 5d7a9bdcd3ee6cc8cdb98bb6427e6084ed0ce0fb2fc0bab279cf37a320ccf029298cb787fca700f113e02e0e241ec26fce60b2932d908ee35e2e6e4cbc2a0475 SHA512 715854701282b85123e47dcf0f7e33d3c00478ec53ecebb29e2ed641cc2cb41c5853cf26f058072d436d215684eef545b33058ac94c1aeb6ee5a26c79daa1bd7
MISC metadata.xml 354 BLAKE2B 003bf0e8c6c7665a205d4dc3c58aa7982877e0d3dcad6706d16cea61a2b53381cb10f4bfdc8a482a8d10c7a1279dc42e542f283dd880e8c258eb7e066eebeca8 SHA512 71adf8afebb39564bd527c758e35f048af6066f4e75db8e1a4b8921af94bdd3f017bf9dd092ecf38ed79de63940dd9f0b89020687092db4a919de5d7dc493ccd
diff --git a/dev-ruby/net-http-persistent/net-http-persistent-4.0.5.ebuild b/dev-ruby/net-http-persistent/net-http-persistent-4.0.5.ebuild
new file mode 100644
index 000000000000..cdc184338ddc
--- /dev/null
+++ b/dev-ruby/net-http-persistent/net-http-persistent-4.0.5.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_EXTRADOC="History.txt README.rdoc"
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Manages persistent connections using Net::HTTP plus a speed fix for Ruby 1.8"
+HOMEPAGE="https://github.com/drbrain/net-http-persistent"
+SRC_URI="https://github.com/drbrain/net-http-persistent/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="doc test"
+
+ruby_add_rdepend ">=dev-ruby/connection_pool-2.2:0"
+
+ruby_add_bdepend "test? ( dev-ruby/minitest )"
+
+all_ruby_prepare() {
+ # Not relevant for us (we're just using rake for the tests)
+ sed -i -e '/require "rake\/manifest"/,/^end/ s:^:#:' Rakefile || die
+
+ # avoid test with implicit dependency on net-http-pipeline which
+ # fails and is not tested upstream
+ sed -i -e '/net-http-pipeline not installed/ s/unless.*$//' test/test_net_http_persistent.rb || die
+}