summaryrefslogtreecommitdiff
path: root/dev-ruby/net-http-persistent
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/net-http-persistent
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/net-http-persistent')
-rw-r--r--dev-ruby/net-http-persistent/Manifest5
-rw-r--r--dev-ruby/net-http-persistent/metadata.xml11
-rw-r--r--dev-ruby/net-http-persistent/net-http-persistent-2.9.4-r2.ebuild32
-rw-r--r--dev-ruby/net-http-persistent/net-http-persistent-3.0.0.ebuild31
4 files changed, 79 insertions, 0 deletions
diff --git a/dev-ruby/net-http-persistent/Manifest b/dev-ruby/net-http-persistent/Manifest
new file mode 100644
index 000000000000..fe0141cca924
--- /dev/null
+++ b/dev-ruby/net-http-persistent/Manifest
@@ -0,0 +1,5 @@
+DIST net-http-persistent-2.9.4.gem 31232 BLAKE2B 54388d26971c3ea3353e0c39acd00fe77befd66e408c54be13f7ecea194517a2e71b8d9bebb1238f4d36d7be96584c0be9e6a7bbc44f81f88004dd118fa56311 SHA512 9251e8422c2f43e7ecd8bc287fa9fff682fac84ed95d143425b0e7e7678a06c9be01db56e6a956588d6c33ddccbd1eff45a6f399f43d452de8e3134e6c50b74e
+DIST net-http-persistent-3.0.0.gem 30208 BLAKE2B 2bbd87d66e65081c76bc9cddaeb38f3ffd8a92b5b64f7717f77c7a927e2032fa732c2e82e220a75a63ddc10dfaa6a0f24e4fa7e0964e2ebd3d0729127f1fb452 SHA512 a601d3abde43b196406e3cdd6b704796ed70db67dfb67c9b510e0164ce7355cc925cac37fbf4c5889f41b069890ba2e2c15440fb40294ed21891fd08d9f87894
+EBUILD net-http-persistent-2.9.4-r2.ebuild 846 BLAKE2B 81858ae68e68062c68c80af17008d98cd8a628e28cd6e8cce47b253661f196046684c041542a9be75a8ea5782b689c2de34244189ef24f6f76ebefccc9b3f268 SHA512 4b707d418ebde88b2b7d7782a9795a1e1b0ede9dd88acd7ca0fe9ffaaf4566d72e3029b11ed294c02413389a1355ed7d4e3dc5647513258eabe7e0d667ca13cb
+EBUILD net-http-persistent-3.0.0.ebuild 883 BLAKE2B 128668d57e186a7550476b2c0bc9f4435e0e978ba07da210a9d37d038672cdd3275fabc2c8d591438b7490aa45577246472460343bcfb622c167f91eca0ff6f3 SHA512 268f2ea1493871e0ed9c4381f62bf155dc8bf46071cd9fff5ec56a791b3db6bba56eb515558e31635c0af45d6f8618b64e13313da537dc8220274c5503069bbf
+MISC metadata.xml 353 BLAKE2B 9c2503aa880a368eb25787d0020bba032b96ad047823434e630864c5569985cddc59fb8cfe458ce2ec7a278759f98c677d0413c70d65f20bf2b11df7c1114c0b SHA512 acff0618bb97cf903d61bf4149537876ba57037cf93c033f7a7c2165682d52216229f5d52166e648e313c7066c25bf3cd70925b5791ac8f77f4c43180555d420
diff --git a/dev-ruby/net-http-persistent/metadata.xml b/dev-ruby/net-http-persistent/metadata.xml
new file mode 100644
index 000000000000..f46d15fc98a1
--- /dev/null
+++ b/dev-ruby/net-http-persistent/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">drbrain/net-http-persistent</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/net-http-persistent/net-http-persistent-2.9.4-r2.ebuild b/dev-ruby/net-http-persistent/net-http-persistent-2.9.4-r2.ebuild
new file mode 100644
index 000000000000..cdcadb22d432
--- /dev/null
+++ b/dev-ruby/net-http-persistent/net-http-persistent-2.9.4-r2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+USE_RUBY="ruby21 ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_DOCDIR="doc"
+
+RUBY_FAKEGEM_EXTRADOC="History.txt README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Manages persistent connections using Net::HTTP plus a speed fix for Ruby 1.8"
+HOMEPAGE="https://github.com/drbrain/net-http-persistent"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~ppc ~ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="doc test"
+
+ruby_add_bdepend "
+ test? ( dev-ruby/hoe dev-ruby/minitest )"
+
+all_ruby_prepare() {
+ # due to hoe
+ sed -i -e "/license/d" Rakefile || die
+
+ # Avoid unsafe legacy SSL version
+ sed -i -e '/ssl_version =/ s/:SSLv3/:TLSv1_2/' test/test_net_http_persistent_ssl_reuse.rb || die
+}
diff --git a/dev-ruby/net-http-persistent/net-http-persistent-3.0.0.ebuild b/dev-ruby/net-http-persistent/net-http-persistent-3.0.0.ebuild
new file mode 100644
index 000000000000..e7b05c4ea0d1
--- /dev/null
+++ b/dev-ruby/net-http-persistent/net-http-persistent-3.0.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+RUBY_FAKEGEM_EXTRADOC="History.txt README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Manages persistent connections using Net::HTTP plus a speed fix for Ruby 1.8"
+HOMEPAGE="https://github.com/drbrain/net-http-persistent"
+
+LICENSE="MIT"
+SLOT="3"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="doc test"
+
+ruby_add_rdepend ">=dev-ruby/connection_pool-2.2:0"
+
+ruby_add_bdepend "
+ test? ( dev-ruby/hoe dev-ruby/minitest )"
+
+all_ruby_prepare() {
+ # avoid test with implicit dependency on net-http-pipeline which
+ # fails and is not tested upstream
+ sed -i -e '/net-http-pipeline not installed/ s/unless.*$//' test/test_net_http_persistent.rb || die
+}