summaryrefslogtreecommitdiff
path: root/dev-ruby/net-http-persistent/net-http-persistent-4.0.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-03 05:19:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-03 05:19:36 +0100
commit155cc74ccaea367efa88c8acfadcf25cb7dfe89c (patch)
tree7c071f2c978804bd5ad135f096c2c1849d338b6f /dev-ruby/net-http-persistent/net-http-persistent-4.0.2.ebuild
parentd288197c01703f58dbea0ff4f42b01e7c4c6f327 (diff)
gentoo auto-resync : 03:04:2023 - 05:19:36
Diffstat (limited to 'dev-ruby/net-http-persistent/net-http-persistent-4.0.2.ebuild')
-rw-r--r--dev-ruby/net-http-persistent/net-http-persistent-4.0.2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ruby/net-http-persistent/net-http-persistent-4.0.2.ebuild b/dev-ruby/net-http-persistent/net-http-persistent-4.0.2.ebuild
new file mode 100644
index 000000000000..f9324771a495
--- /dev/null
+++ b/dev-ruby/net-http-persistent/net-http-persistent-4.0.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby27 ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_EXTRADOC="History.txt README.rdoc"
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Manages persistent connections using Net::HTTP plus a speed fix for Ruby 1.8"
+HOMEPAGE="https://github.com/drbrain/net-http-persistent"
+SRC_URI="https://github.com/drbrain/net-http-persistent/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
+IUSE="doc test"
+
+ruby_add_rdepend ">=dev-ruby/connection_pool-2.2:0"
+
+ruby_add_bdepend "test? ( dev-ruby/minitest )"
+
+all_ruby_prepare() {
+ # Not relevant for us (we're just using rake for the tests)
+ sed -i -e '/require "rake\/manifest"/,/^end/ s:^:#:' Rakefile || die
+
+ # avoid test with implicit dependency on net-http-pipeline which
+ # fails and is not tested upstream
+ sed -i -e '/net-http-pipeline not installed/ s/unless.*$//' test/test_net_http_persistent.rb || die
+}