summaryrefslogtreecommitdiff
path: root/dev-ruby/net-http-digest_auth/net-http-digest_auth-1.4.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-02-13 21:41:11 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-02-13 21:41:11 +0000
commitc8d60dada2ec8eb48b2d2b290cd6683ccec40e39 (patch)
treec44943ee0563a3fa957716de909fed683117fcb9 /dev-ruby/net-http-digest_auth/net-http-digest_auth-1.4.1-r1.ebuild
parent69051588e2f955485fe5d45d45e616bc60a2de57 (diff)
gentoo (valentine's day) resync : 14.02.2021
Diffstat (limited to 'dev-ruby/net-http-digest_auth/net-http-digest_auth-1.4.1-r1.ebuild')
-rw-r--r--dev-ruby/net-http-digest_auth/net-http-digest_auth-1.4.1-r1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ruby/net-http-digest_auth/net-http-digest_auth-1.4.1-r1.ebuild b/dev-ruby/net-http-digest_auth/net-http-digest_auth-1.4.1-r1.ebuild
new file mode 100644
index 000000000000..52b2b62e979e
--- /dev/null
+++ b/dev-ruby/net-http-digest_auth/net-http-digest_auth-1.4.1-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby25 ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_EXTRADOC="History.txt README.txt"
+
+inherit ruby-fakegem
+
+DESCRIPTION="An implementation of RFC 2617 - Digest Access Authentication"
+HOMEPAGE="https://github.com/drbrain/net-http-digest_auth"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
+IUSE="test"
+
+ruby_add_bdepend "test? ( dev-ruby/minitest )"
+
+each_ruby_test() {
+ ${RUBY} -Ilib:. -e 'Dir["test/test_*.rb"].each{|f| require f}' || die
+}