summaryrefslogtreecommitdiff
path: root/dev-ruby/narray
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/narray
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/narray')
-rw-r--r--dev-ruby/narray/Manifest3
-rw-r--r--dev-ruby/narray/metadata.xml11
-rw-r--r--dev-ruby/narray/narray-0.6.1.2.ebuild49
3 files changed, 63 insertions, 0 deletions
diff --git a/dev-ruby/narray/Manifest b/dev-ruby/narray/Manifest
new file mode 100644
index 000000000000..8e7c08779552
--- /dev/null
+++ b/dev-ruby/narray/Manifest
@@ -0,0 +1,3 @@
+DIST narray-0.6.1.2.tar.gz 68621 BLAKE2B c4e48b81fb0d79cc49e32ed8204d9cac3f483eb44e1207f422f5b272bb8891836d81cd83c090f4d643677b1159801c13d15580504e6ca244a2a75d4b6dfb3204 SHA512 51e9bec0b711e79e268b73496ad742b80bb46a6e9ea6aab9a2535a700b6efc8f7ae2e854f5772d434e3d385d81275744dbc796ebec4d3de73f2ec0546bd2339a
+EBUILD narray-0.6.1.2.ebuild 1289 BLAKE2B 8e100bbd20351ca5b973696d76c247c52c14a7eb4ae80037fc91093e109af3b2f90930d3a353ad24596a8828972582a7ea1d80baa026193058b010446992caf3 SHA512 b0368cbc286bc0b3437dd33f1d2145067b58942950531ee93d3a344439155d45d6e11edd772b66d677166b256631ea42756b1b26233a16841296ecfcac09ee4e
+MISC metadata.xml 339 BLAKE2B 9337a45d749879673fc180a12d5e7d27326fdfcf326f86ccc45fc2ad10b7eff1c4575c1379fb6b634f1482b7adb40531f78cc0b556148fdd622b9807e11122b6 SHA512 47c9372c3fa2a28f5d728cd9d3df7b030c2e0bb2378099c287018cd55324a188eb2ef8c901b52acfd87d278c4990752a4860a7281e062f4209bf92c10bdc36e2
diff --git a/dev-ruby/narray/metadata.xml b/dev-ruby/narray/metadata.xml
new file mode 100644
index 000000000000..27c7e23b9b09
--- /dev/null
+++ b/dev-ruby/narray/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">masa16/narray</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/narray/narray-0.6.1.2.ebuild b/dev-ruby/narray/narray-0.6.1.2.ebuild
new file mode 100644
index 000000000000..eeb30014535e
--- /dev/null
+++ b/dev-ruby/narray/narray-0.6.1.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+USE_RUBY="ruby22 ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="ChangeLog README.md README.ja.md SPEC.en.txt SPEC.ja.txt"
+
+RUBY_FAKEGEM_VERSION="${PV/_p/.}"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="Numerical N-dimensional Array class"
+HOMEPAGE="http://www.ir.isas.ac.jp/~masa/ruby/index-e.html"
+SRC_URI="https://github.com/masa16/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="amd64 hppa ~mips ppc ~ppc64 x86"
+
+IUSE=""
+
+all_ruby_prepare() {
+ # the tests aren't really written to be a testsuite, so the
+ # failure cases will literally fail; ignore all of those and
+ # instead expect that the rest won't fail.
+ sed -i -e '/[fF]ollowing will fail/,$ s:^:#:' \
+ -e '/next will fail/,$ s:^:#:' \
+ test/*.rb || die "sed failed"
+}
+
+each_ruby_configure() {
+ ${RUBY} extconf.rb || die "extconf.rb failed"
+}
+
+each_ruby_compile() {
+ emake V=1 CFLAGS="${CFLAGS} -fPIC" archflag="${LDFLAGS}"
+ cp -l ${PN}$(get_modname) ${PN}.h ${PN}_config.h lib/ || die "copy of ${PN}$(get_modname) failed"
+}
+
+each_ruby_test() {
+ for unit in test/*; do
+ ${RUBY} -Ilib ${unit} || die "test ${unit} failed"
+ done
+}