summaryrefslogtreecommitdiff
path: root/dev-ruby/multi_xml/multi_xml-0.6.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-07 11:42:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-07 11:42:03 +0100
commitf70601e0934acd62f6c5d06c5ede4cc607179514 (patch)
tree0b337390375de04b950fc4b45edc0f895a4701a4 /dev-ruby/multi_xml/multi_xml-0.6.0-r1.ebuild
parentb2be182d49eea46686b5cf2680d457df61e89dc4 (diff)
gentoo resync : 07.07.2018
Diffstat (limited to 'dev-ruby/multi_xml/multi_xml-0.6.0-r1.ebuild')
-rw-r--r--dev-ruby/multi_xml/multi_xml-0.6.0-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-ruby/multi_xml/multi_xml-0.6.0-r1.ebuild b/dev-ruby/multi_xml/multi_xml-0.6.0-r1.ebuild
new file mode 100644
index 000000000000..e995f1ad7202
--- /dev/null
+++ b/dev-ruby/multi_xml/multi_xml-0.6.0-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_TASK_DOC="yard"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A generic swappable back-end for XML parsing"
+HOMEPAGE="https://www.rubydoc.info/gems/multi_xml"
+SRC_URI="https://github.com/sferik/multi_xml/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="MIT"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+SLOT="0"
+IUSE=""
+
+ruby_add_bdepend "doc? ( dev-ruby/yard )"
+ruby_add_bdepend "test? ( dev-ruby/ox )"
+
+all_ruby_prepare() {
+ eapply "${FILESDIR}/${P}-ox24.patch"
+
+ sed -i -e '/simplecov/,/^end/ s:^:#:' spec/helper.rb || die
+ sed -i -e '/bundler/I s:^:#:' -e '/yardstick/,/end/ s:^:#:' Rakefile || die
+}
+
+each_ruby_test() {
+ CI=true each_fakegem_test
+}