summaryrefslogtreecommitdiff
path: root/dev-ruby/multi_json
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-11-03 16:06:58 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-11-03 16:06:58 +0000
commitbd4aeefe33e63f613512604e47bfca7b2187697d (patch)
treeadb35b5a9a00ee7ea591ab0c987f70167c23b597 /dev-ruby/multi_json
parent48ece6662cbd443015f5a57ae6d8cbdbd69ef37c (diff)
gentoo resync : 03.11.2019
Diffstat (limited to 'dev-ruby/multi_json')
-rw-r--r--dev-ruby/multi_json/Manifest4
-rw-r--r--dev-ruby/multi_json/multi_json-1.14.0.ebuild62
-rw-r--r--dev-ruby/multi_json/multi_json-1.14.1.ebuild62
3 files changed, 128 insertions, 0 deletions
diff --git a/dev-ruby/multi_json/Manifest b/dev-ruby/multi_json/Manifest
index b494763af978..ab5e599f8744 100644
--- a/dev-ruby/multi_json/Manifest
+++ b/dev-ruby/multi_json/Manifest
@@ -1,3 +1,7 @@
DIST multi_json-1.13.1.tar.gz 26098 BLAKE2B e82a08a747a092a9094cd7b35b4f933b5ac922a01f45a51b215ca9c4cdb9a083a4808d4bbe67a147ecb57e0b7b7e313c3d896f8cd80c79338c24abc3b90a09f9 SHA512 7c98392bd1c909fcc05249a02a010b561bf6c2d812ae42413d6e8dafa62926d8cb76226ded4c61558a00e5fa531ba33b6f4ef562648c52ba9b552ff7b7e27682
+DIST multi_json-1.14.0.tar.gz 24558 BLAKE2B 78138ab956f71d5875d3ca0d0a7b10fc93fa303648de8515d705ac5e24ed5cf84b425ef4aeebb1ef80862cad373698c2f57eddf17e6558d810edd1a3da2ec342 SHA512 dc2adaa9b5092c653b0a6365ad254a8b920f391123c2625c6ea8168c675346da69f1f003face872e66f493e078f511872d3715e4eef242627b0862cdf4aa3735
+DIST multi_json-1.14.1.tar.gz 24713 BLAKE2B 188d0fa3bf7a46a6cf4a5aa1d613523b4da3dee5061a5288146d1a367835b255f103dec265da9a218dd6dd21ecb38a7ce35d16a758ac7754b440f52c25f0b703 SHA512 19e2b6704a8ed39b8714da449c8961e740198772718ddba3d3b651f71f2b7d8c2c198d9cc16fe290f1df7b1e54d029c01147fdc431a8d2763944a4de802b89d9
EBUILD multi_json-1.13.1.ebuild 1919 BLAKE2B 5b595fec88c3ffcabb3042888639fbc86a21e65c62f4bca4b4edbd3d39f7b339c619012f51e335cc52bebdb9bec8df3d2e952a6da7b47b66107844ed600dd46b SHA512 00993ecb67fbd6f43c4f9127685b10a2acc183aab9868c6900f8e647eccff5a7a4d02ca95aea07b06ba78b041738185cc531ef1b974a727f2077e2a02588654e
+EBUILD multi_json-1.14.0.ebuild 1981 BLAKE2B 978456342229b4eec46a289d764cd60f04f91bbcf2cdc4fb2bc79a7730d4393e64dc2fdcbf7cea7c9c7edccb316607fd0c1f552c63f0306591554828c4ad9984 SHA512 efd7c208f37f90536b7067892a88ebbe6dbf7009a9016c44fdb2690301455a369ecbfaccdc298827eac50770a172fe0bd6059866b44af6cef5c4de2d6f289a99
+EBUILD multi_json-1.14.1.ebuild 1981 BLAKE2B 978456342229b4eec46a289d764cd60f04f91bbcf2cdc4fb2bc79a7730d4393e64dc2fdcbf7cea7c9c7edccb316607fd0c1f552c63f0306591554828c4ad9984 SHA512 efd7c208f37f90536b7067892a88ebbe6dbf7009a9016c44fdb2690301455a369ecbfaccdc298827eac50770a172fe0bd6059866b44af6cef5c4de2d6f289a99
MISC metadata.xml 345 BLAKE2B 7d7684a1546dcc97e934f1a7df4484b568c5e8043dcfd0493e03124fa9f96959de5dccb78d22b1ff51ebc39b5fbec8b9a1dfd24531d676b8982b1f1dbd5097d0 SHA512 5fe7f117806d67e0d295bfcbdd07d4bbe8d3c3875e07cc3d276f2aee81b89f2e90174cbf4264d647384817fe0e8c81c2f2c9d9d67e3f78b46c3c194001bcace9
diff --git a/dev-ruby/multi_json/multi_json-1.14.0.ebuild b/dev-ruby/multi_json/multi_json-1.14.0.ebuild
new file mode 100644
index 000000000000..776ba06afcb5
--- /dev/null
+++ b/dev-ruby/multi_json/multi_json-1.14.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_TASK_DOC="yard"
+
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="multi_json.gemspec"
+
+inherit ruby-fakegem
+
+SRC_URI="https://github.com/intridea/multi_json/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+DESCRIPTION="A gem to provide swappable JSON backends"
+HOMEPAGE="https://github.com/intridea/multi_json"
+LICENSE="MIT"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+SLOT="0"
+IUSE=""
+
+ruby_add_rdepend "|| ( >=dev-ruby/json-1.4:* >=dev-ruby/yajl-ruby-1.0 )"
+
+ruby_add_bdepend "doc? ( dev-ruby/rspec:3 dev-ruby/yard )"
+
+ruby_add_bdepend "test? ( dev-ruby/json
+ dev-ruby/yajl-ruby )"
+
+all_ruby_prepare() {
+ sed -i -e '/[Bb]undler/d' Rakefile spec/spec_helper.rb || die "Unable to remove bundler."
+
+ # Remove unimportant rspec options not supported by rspec 2.6.
+ rm .rspec || die
+
+ # Remove specs specific to oj since we don't package oj yet.
+ sed -i -e '/defaults to the best available gem/,/^ end/ s:^:#:' \
+ -e '/Oj does not create symbols on parse/,/^ end/ s:^:#:' \
+ -e '/with Oj.default_settings/,/^ end/ s:^:#:' \
+ -e '/using one-shot parser/,/^ end/ s:^:#:' \
+ -e '/jrjackson/askip "unpackaged"' \
+ spec/multi_json_spec.rb
+
+ # Avoid simplecov which only works with ruby 1.9
+ sed -i -e '/simplecov/d' -e '/SimpleCov.formatter/,/SimpleCov.start/ d' spec/spec_helper.rb || die
+
+ # Remove unpackaged and for our purposes unneeded coveralls
+ sed -i -e '/coveralls/d' spec/spec_helper.rb || die
+
+ # Avoid testing unpackaged adapters
+ rm spec/{gson,nsjsonserialization,jr_jackson,oj}_adapter_spec.rb || die
+}
+
+each_ruby_test() {
+ for t in spec/*_spec.rb; do
+ ${RUBY} -S rspec-3 ${t} || die
+ done
+}
diff --git a/dev-ruby/multi_json/multi_json-1.14.1.ebuild b/dev-ruby/multi_json/multi_json-1.14.1.ebuild
new file mode 100644
index 000000000000..776ba06afcb5
--- /dev/null
+++ b/dev-ruby/multi_json/multi_json-1.14.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_TASK_DOC="yard"
+
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="multi_json.gemspec"
+
+inherit ruby-fakegem
+
+SRC_URI="https://github.com/intridea/multi_json/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+DESCRIPTION="A gem to provide swappable JSON backends"
+HOMEPAGE="https://github.com/intridea/multi_json"
+LICENSE="MIT"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+SLOT="0"
+IUSE=""
+
+ruby_add_rdepend "|| ( >=dev-ruby/json-1.4:* >=dev-ruby/yajl-ruby-1.0 )"
+
+ruby_add_bdepend "doc? ( dev-ruby/rspec:3 dev-ruby/yard )"
+
+ruby_add_bdepend "test? ( dev-ruby/json
+ dev-ruby/yajl-ruby )"
+
+all_ruby_prepare() {
+ sed -i -e '/[Bb]undler/d' Rakefile spec/spec_helper.rb || die "Unable to remove bundler."
+
+ # Remove unimportant rspec options not supported by rspec 2.6.
+ rm .rspec || die
+
+ # Remove specs specific to oj since we don't package oj yet.
+ sed -i -e '/defaults to the best available gem/,/^ end/ s:^:#:' \
+ -e '/Oj does not create symbols on parse/,/^ end/ s:^:#:' \
+ -e '/with Oj.default_settings/,/^ end/ s:^:#:' \
+ -e '/using one-shot parser/,/^ end/ s:^:#:' \
+ -e '/jrjackson/askip "unpackaged"' \
+ spec/multi_json_spec.rb
+
+ # Avoid simplecov which only works with ruby 1.9
+ sed -i -e '/simplecov/d' -e '/SimpleCov.formatter/,/SimpleCov.start/ d' spec/spec_helper.rb || die
+
+ # Remove unpackaged and for our purposes unneeded coveralls
+ sed -i -e '/coveralls/d' spec/spec_helper.rb || die
+
+ # Avoid testing unpackaged adapters
+ rm spec/{gson,nsjsonserialization,jr_jackson,oj}_adapter_spec.rb || die
+}
+
+each_ruby_test() {
+ for t in spec/*_spec.rb; do
+ ${RUBY} -S rspec-3 ${t} || die
+ done
+}