summaryrefslogtreecommitdiff
path: root/dev-ruby/multi_json
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-10 05:25:01 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-10 05:25:01 +0000
commit456dbeaab3e2f71f527eae542ab44d1e372b0655 (patch)
tree5cee708ec6e4b4e530a4337e7389598dc7cd6144 /dev-ruby/multi_json
parent65737cf14a7220bd9a487aa2af4ae0e79bd23e86 (diff)
gentoo resync : 10.01.2018
Diffstat (limited to 'dev-ruby/multi_json')
-rw-r--r--dev-ruby/multi_json/Manifest2
-rw-r--r--dev-ruby/multi_json/multi_json-1.13.0.ebuild61
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-ruby/multi_json/Manifest b/dev-ruby/multi_json/Manifest
index 199eae746796..d5b35624929e 100644
--- a/dev-ruby/multi_json/Manifest
+++ b/dev-ruby/multi_json/Manifest
@@ -1,5 +1,7 @@
DIST multi_json-1.12.1.tar.gz 25579 BLAKE2B 50fa37b907289b8247ffff1e22ebde1b07ee32e5ca97984be1243340f14185ebaaeb72cb28a18c5c77b1b48bfd0b400479fe7ef532e40cef3736d782c84c0d09 SHA512 f61e500197c5a1373443b308bd9307238c54d2d23ba9da91843c667c12e491f34fd87575028c3630a81a7355d4903344996f20408bbb7971b12dfba3cc4f76df
DIST multi_json-1.12.2.tar.gz 25630 BLAKE2B 61209dc4be50b44302cfe40e45b840ae8d81e827d8b9df82ca6b852a72d360fbe09c0f5b0ef8eecfbd08b6bd08343ab7bb307d91d9abf28c9b9adb35f18bea51 SHA512 bbbdd05a6dd12052aa3e09389f47212f15799310d5c265057f7ca801622d32295d1f0844b37e51f8f1fd2d48e4430234f99bc6de4b9ed149e81d9a33a831e6d9
+DIST multi_json-1.13.0.tar.gz 25954 BLAKE2B 22a2f2ff2f1291a45613f456661a1735fc41ad80f28ee7d2c9b97109f0637da4e60439686cfc29b7ced501c32d2fe9236c9acc25acc0f55e57ec0bfe53331f37 SHA512 b168b2a093865f48f1a4d1941e8cfead8b3efba73bcd59660dae581a77ab7149f0f452f1280e69061187f35c84b6eeff70144f815f9f669db03dba49100143aa
EBUILD multi_json-1.12.1.ebuild 1926 BLAKE2B f392a89f6f23033080a4ec1fa22b638f41a44f00638a0ccf1fbe34dc70150082b0e3eaa5b926df620efd7676bab3f31fd197ea0f99496cddc918d93ef4abada3 SHA512 9cc52c4e92ef2c398bc05ae8dd53ba440dd3713b3713972bb44ae6aa5881e13b7b79a382b16abf64e75da531f35871b0a98ae8470fab1e9b6b4cdc7c6c3442d3
EBUILD multi_json-1.12.2.ebuild 1922 BLAKE2B 338cbc039830d46a7cebb61b82ee7fcce1b6722a7de17a9cff0ff1372c12c7157d01bf0c8b1fe05cf81d2f5a4b51aaecaf807ee6563b84ce31e843963e78c992 SHA512 429d8f7036473500cc478d690e28ab4baab02cce66a474f0c73e03b2362e3b9124248520bca8ce1c2c89ab46f6ca41dab196b654919f8bd43e66e76c6e04e9cc
+EBUILD multi_json-1.13.0.ebuild 1922 BLAKE2B c909ef211d008b8f12d400319e89674f79cc556d4f3aeea0d5b76c7c43ec671f2a4e6e48fd3f1861f7c157668778a86cbdf151f77bdf64392f0be4a859aa0695 SHA512 170aa5bb583feeef39ca4600bdfba839e7b640a4ac376de56e42641eec72650b536ccc16a1fc8065c843ffaddf2b1655bac68608804abc669f5b67be7146c39c
MISC metadata.xml 345 BLAKE2B 7d7684a1546dcc97e934f1a7df4484b568c5e8043dcfd0493e03124fa9f96959de5dccb78d22b1ff51ebc39b5fbec8b9a1dfd24531d676b8982b1f1dbd5097d0 SHA512 5fe7f117806d67e0d295bfcbdd07d4bbe8d3c3875e07cc3d276f2aee81b89f2e90174cbf4264d647384817fe0e8c81c2f2c9d9d67e3f78b46c3c194001bcace9
diff --git a/dev-ruby/multi_json/multi_json-1.13.0.ebuild b/dev-ruby/multi_json/multi_json-1.13.0.ebuild
new file mode 100644
index 000000000000..819f95007369
--- /dev/null
+++ b/dev-ruby/multi_json/multi_json-1.13.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_TASK_DOC="yard"
+
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="multi_json.gemspec"
+
+inherit ruby-fakegem
+
+SRC_URI="https://github.com/intridea/multi_json/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+DESCRIPTION="A gem to provide swappable JSON backends"
+HOMEPAGE="https://github.com/intridea/multi_json"
+LICENSE="MIT"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+SLOT="0"
+IUSE=""
+
+ruby_add_rdepend "|| ( >=dev-ruby/json-1.4:* >=dev-ruby/yajl-ruby-1.0 )"
+
+ruby_add_bdepend "doc? ( dev-ruby/rspec:3 dev-ruby/yard )"
+
+ruby_add_bdepend "test? ( dev-ruby/json
+ dev-ruby/yajl-ruby )"
+
+all_ruby_prepare() {
+ sed -i -e '/[Bb]undler/d' Rakefile spec/spec_helper.rb || die "Unable to remove bundler."
+
+ # Remove unimportant rspec options not supported by rspec 2.6.
+ rm .rspec || die
+
+ # Remove specs specific to oj since we don't package oj yet.
+ sed -i -e '/defaults to the best available gem/,/^ end/ s:^:#:' \
+ -e '/Oj does not create symbols on parse/,/^ end/ s:^:#:' \
+ -e '/with Oj.default_settings/,/^ end/ s:^:#:' \
+ -e '/using one-shot parser/,/^ end/ s:^:#:' \
+ spec/multi_json_spec.rb
+
+ # Avoid simplecov which only works with ruby 1.9
+ sed -i -e '/simplecov/d' -e '/SimpleCov.formatter/,/SimpleCov.start/ d' spec/spec_helper.rb || die
+
+ # Remove unpackaged and for our purposes unneeded coveralls
+ sed -i -e '/coveralls/d' spec/spec_helper.rb || die
+
+ # Avoid testing unpackaged adapters
+ rm spec/{gson,jr_jackson,oj}_adapter_spec.rb || die
+}
+
+each_ruby_test() {
+ for t in spec/*_spec.rb; do
+ ${RUBY} -S rspec-3 ${t} || die
+ done
+}