summaryrefslogtreecommitdiff
path: root/dev-ruby/multi_json
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-ruby/multi_json
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-ruby/multi_json')
-rw-r--r--dev-ruby/multi_json/Manifest2
-rw-r--r--dev-ruby/multi_json/multi_json-1.15.0.ebuild62
2 files changed, 64 insertions, 0 deletions
diff --git a/dev-ruby/multi_json/Manifest b/dev-ruby/multi_json/Manifest
index efff4bdcc3a3..4828a2f7b16d 100644
--- a/dev-ruby/multi_json/Manifest
+++ b/dev-ruby/multi_json/Manifest
@@ -1,5 +1,7 @@
DIST multi_json-1.13.1.tar.gz 26098 BLAKE2B e82a08a747a092a9094cd7b35b4f933b5ac922a01f45a51b215ca9c4cdb9a083a4808d4bbe67a147ecb57e0b7b7e313c3d896f8cd80c79338c24abc3b90a09f9 SHA512 7c98392bd1c909fcc05249a02a010b561bf6c2d812ae42413d6e8dafa62926d8cb76226ded4c61558a00e5fa531ba33b6f4ef562648c52ba9b552ff7b7e27682
DIST multi_json-1.14.1.tar.gz 24713 BLAKE2B 188d0fa3bf7a46a6cf4a5aa1d613523b4da3dee5061a5288146d1a367835b255f103dec265da9a218dd6dd21ecb38a7ce35d16a758ac7754b440f52c25f0b703 SHA512 19e2b6704a8ed39b8714da449c8961e740198772718ddba3d3b651f71f2b7d8c2c198d9cc16fe290f1df7b1e54d029c01147fdc431a8d2763944a4de802b89d9
+DIST multi_json-1.15.0.tar.gz 24932 BLAKE2B c99c5c6b152c91dedc38fd24f8697f918064c603bfd72c55213f3ac8afd14d3c0ba31b7c3fb91c9998fcc8a5386f41a6983c53b40119558b99194ba58c06cc91 SHA512 55c873e45cdc59e75823aa031eb6d792cb9dc744b13a682fc279a8375b925db7a984256d61aa5454795a59722794a774a0ed5b6bf518db253152f4af67f46dea
EBUILD multi_json-1.13.1.ebuild 1908 BLAKE2B 47c9e593445a9597164535186839fff55f3b2637f0d936e939731d375047587701e20a237b288b4218ea9f5d251e02eab560ddbaafa31c42f3cd69edbe4beb41 SHA512 88c6571c406e1323fe456a02a1037da689d06d00e5138a7c68d53c067e315fe29947a5168b32ad4ed69a69253fed5148c86e633d1c4f5135ff622832ba5652cd
EBUILD multi_json-1.14.1.ebuild 1968 BLAKE2B 3454c739720ed206a26f8acf1fb33095708842af64eb13e577c8effbc3ce0a654b2c6fb76aca6a9e6288814117859ed94a9f19c1d35ef6e58e70441bf243bc0a SHA512 b928c89017ce84ba990b3c03aa4c74398b9b6c718167ed5e7cc9e9d18506954ef42c7b62ffcc1b51ba4992b36c8c495934ae8f6cd67b2e3dd16f177c79d27cde
+EBUILD multi_json-1.15.0.ebuild 1968 BLAKE2B 641843d31c77760261e556a6e8277ca1c64e1400027eeb0ceb2a3243f3f99d5eb4a397637154aee891a40aa4bfdae801343be39b77af82f928756d1a2ac96227 SHA512 ff7a796705cb587ecc1ecb9f2bccbb6f974cdf4f9c01cd54900891e2ffa5ff58d816df4a9457733ef877303317a4b9537f85dfc26639e7a6dc785ce0903fd2a2
MISC metadata.xml 345 BLAKE2B 7d7684a1546dcc97e934f1a7df4484b568c5e8043dcfd0493e03124fa9f96959de5dccb78d22b1ff51ebc39b5fbec8b9a1dfd24531d676b8982b1f1dbd5097d0 SHA512 5fe7f117806d67e0d295bfcbdd07d4bbe8d3c3875e07cc3d276f2aee81b89f2e90174cbf4264d647384817fe0e8c81c2f2c9d9d67e3f78b46c3c194001bcace9
diff --git a/dev-ruby/multi_json/multi_json-1.15.0.ebuild b/dev-ruby/multi_json/multi_json-1.15.0.ebuild
new file mode 100644
index 000000000000..88d2b50255e2
--- /dev/null
+++ b/dev-ruby/multi_json/multi_json-1.15.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_TASK_DOC="yard"
+
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="multi_json.gemspec"
+
+inherit ruby-fakegem
+
+SRC_URI="https://github.com/intridea/multi_json/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+DESCRIPTION="A gem to provide swappable JSON backends"
+HOMEPAGE="https://github.com/intridea/multi_json"
+LICENSE="MIT"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+SLOT="0"
+IUSE=""
+
+ruby_add_rdepend "|| ( >=dev-ruby/json-1.4:* >=dev-ruby/yajl-ruby-1.0 )"
+
+ruby_add_bdepend "doc? ( dev-ruby/rspec:3 dev-ruby/yard )"
+
+ruby_add_bdepend "test? ( dev-ruby/json
+ dev-ruby/yajl-ruby )"
+
+all_ruby_prepare() {
+ sed -i -e '/[Bb]undler/d' Rakefile spec/spec_helper.rb || die "Unable to remove bundler."
+
+ # Remove unimportant rspec options not supported by rspec 2.6.
+ rm .rspec || die
+
+ # Remove specs specific to oj since we don't package oj yet.
+ sed -i -e '/defaults to the best available gem/,/^ end/ s:^:#:' \
+ -e '/Oj does not create symbols on parse/,/^ end/ s:^:#:' \
+ -e '/with Oj.default_settings/,/^ end/ s:^:#:' \
+ -e '/using one-shot parser/,/^ end/ s:^:#:' \
+ -e '/jrjackson/askip "unpackaged"' \
+ spec/multi_json_spec.rb
+
+ # Avoid simplecov which only works with ruby 1.9
+ sed -i -e '/simplecov/d' -e '/SimpleCov.formatter/,/SimpleCov.start/ d' spec/spec_helper.rb || die
+
+ # Remove unpackaged and for our purposes unneeded coveralls
+ sed -i -e '/coveralls/d' spec/spec_helper.rb || die
+
+ # Avoid testing unpackaged adapters
+ rm spec/{gson,nsjsonserialization,jr_jackson,oj}_adapter_spec.rb || die
+}
+
+each_ruby_test() {
+ for t in spec/*_spec.rb; do
+ ${RUBY} -S rspec-3 ${t} || die
+ done
+}