summaryrefslogtreecommitdiff
path: root/dev-ruby/mixlib-shellout
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-12 10:27:43 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-12 10:27:43 +0000
commitf1535b44d6fda761018ea432a180dcb482e97652 (patch)
tree0c17b546154f9b91340a45d84b5dc42dc12c7713 /dev-ruby/mixlib-shellout
parentcdc1eda9c1ad611dd737415be2790c8f44812f1c (diff)
gentoo auto-resync : 12:11:2023 - 10:27:42
Diffstat (limited to 'dev-ruby/mixlib-shellout')
-rw-r--r--dev-ruby/mixlib-shellout/Manifest2
-rw-r--r--dev-ruby/mixlib-shellout/mixlib-shellout-3.2.7.ebuild33
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-ruby/mixlib-shellout/Manifest b/dev-ruby/mixlib-shellout/Manifest
index f73210d29375..0d46cba60be4 100644
--- a/dev-ruby/mixlib-shellout/Manifest
+++ b/dev-ruby/mixlib-shellout/Manifest
@@ -1,3 +1,5 @@
DIST mixlib-shellout-3.0.9.tar.gz 42476 BLAKE2B 4fab1d0f7d7ee5190f65d312304c7137d940b5cc19bb205d4de1d14eb5bc5829671560785b7f3179220246433b15b9022f8a1d16fb7491e180940c9dc6da5280 SHA512 7234c188e25cc6da3c4859eb12e4f86ce0d6538d17e4c90b1b5105fe677fcd13d884d7045be9767473c3ac63ffcfac7af25dc8efcec184928ba32852a5a760cc
+DIST mixlib-shellout-3.2.7.tar.gz 46666 BLAKE2B 0ee97eef27618d326487a3884115d0954147297a75001404c8df0717f71c6acde5ec9ebc9320d12493f1ce4e65b3d74ba1143ba7e4a631629de0d65e3b50bcb7 SHA512 de1d07e7a3f26ec934f57a37a82995b5522a5c196263b7ff1917c1a77cce3104d67a8dccab2aa907c3db854520ce6b5f78ef33fca8d4bffd0ba0cc659da1c16f
EBUILD mixlib-shellout-3.0.9-r1.ebuild 902 BLAKE2B 324d2f38b73857cb795c1bb539da6cb0f81f33cb1d2d1c6df5ee9f9426031f3a25296a1a59072a8a2206deafb1d4886016202d39051eac638505aa89f7e4638b SHA512 7ae859ae3b31a1b900300f1c0aa183bb74a834e2ec7387509b1aa67a4d51ccc0c101950dc837b71a9bd8a760df3966d3f70635f409a3b93614ae5df1b91da275
+EBUILD mixlib-shellout-3.2.7.ebuild 930 BLAKE2B cbe95841cbc59e9278e09d201ac1026f4f831728b1c62c24f014462a33604d62aab1392e2a8527ca0fd4e7522ba9845d042f3b4717014d053ac8ed76962a9caf SHA512 d7d652e455c8aede823fa1a5665d3ccc34aa5a7f93fc5c53afe8aa5316d3518e30c85f09a8016543cb75e250e6d1f41ff3c4004dae8f70df4652113ce9fefafb
MISC metadata.xml 347 BLAKE2B ab588c71a4d6866a8524826b4241ff8ecc36719eadda2690954e9039c5395ce54a5c6f3a48c69fff6adc4af39ad30cecbb18d4d3e91c29eba461ed02406cb33f SHA512 836e04df48dcb26a162cfc682eec084d1b5ad570afec8cf092581f0017717bdf141460b2bfc14e4f06d2b3ced2818474fc5044a460117d327af551f3a3d635bb
diff --git a/dev-ruby/mixlib-shellout/mixlib-shellout-3.2.7.ebuild b/dev-ruby/mixlib-shellout/mixlib-shellout-3.2.7.ebuild
new file mode 100644
index 000000000000..5c3ef41fe0bd
--- /dev/null
+++ b/dev-ruby/mixlib-shellout/mixlib-shellout-3.2.7.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRA_DOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="mixlib-shellout.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Run external commands on Unix or Windows"
+HOMEPAGE="https://github.com/chef/mixlib-shellout"
+SRC_URI="https://github.com/chef/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend "dev-ruby/chef-utils"
+
+each_ruby_prepare() {
+ # Make sure we actually use the right interpreter for testing
+ sed -i -e "/ruby_eval/ s:ruby :${RUBY} :" spec/mixlib/shellout_spec.rb || die
+
+ # Avoid spec that requires an interactive terminal
+ sed -e '/with subprocess writing lots of data to both stdout and stderr/,/^ end/ s:^:#:' \
+ -i spec/mixlib/shellout_spec.rb || die
+}