summaryrefslogtreecommitdiff
path: root/dev-ruby/mixlib-shellout
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-04 08:53:53 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-04 08:53:53 +0100
commite3872864be25f7421015bef2732fa57c0c9fb726 (patch)
tree9cb29a544215119b5c5538e37211b994ce1c87ae /dev-ruby/mixlib-shellout
parent480486b52ea64765faf696c88b2c6a26a5a454d4 (diff)
gentoo resync : 04.08.2018
Diffstat (limited to 'dev-ruby/mixlib-shellout')
-rw-r--r--dev-ruby/mixlib-shellout/Manifest2
-rw-r--r--dev-ruby/mixlib-shellout/mixlib-shellout-2.4.0.ebuild26
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-ruby/mixlib-shellout/Manifest b/dev-ruby/mixlib-shellout/Manifest
index 26786c1438c9..b25a540343c8 100644
--- a/dev-ruby/mixlib-shellout/Manifest
+++ b/dev-ruby/mixlib-shellout/Manifest
@@ -1,3 +1,5 @@
DIST mixlib-shellout-2.3.2.tar.gz 35828 BLAKE2B 8fa665a0be90da481d2e83aeb0bbfe35be6086cad25cfff5f079f0aa53926318961d2192da3477e4a4cd728e57752f32652579d544f562d81941a3d357c5bb5a SHA512 72f4979d1c444b1f097ecfd4767a2989e60398e84a78106b80077b664bc01d6fc68022cec26172f1e7c0384dd3fc4f64c723ad3a2882db7284dbadacc7cf24c9
+DIST mixlib-shellout-2.4.0.tar.gz 36249 BLAKE2B cf2da1936a95ace0d2f847c05e299834ea0fcb00ec47e6caeeb5b8e0e96d76b69ba9a43ce9846079ca707e4877c0a2bcde35a67a4d4f27e79192d2b88a97a653 SHA512 fccd70854449303aa107eeba0d7d58b5a0ff5db8aaeb52e49121340aefdeb25fe205f3a8cc80299e24c72ec99f89988c559ca72086610d39c6847b2208e95d57
EBUILD mixlib-shellout-2.3.2.ebuild 704 BLAKE2B b14580e6ad10a522475542cdc2f185b82ffeb20f36012b35a04a048678dc3ca9f4fedde9946fdcb67a412c706632a813d7bdec594614c3be04cb00e9adc429a8 SHA512 9fa00797118c24474e0052210ab603bd5b3d9c89829427793c10a38bd8cb4523c271be35dbe681c4f9610eab797404bbcf8502768473d791a73d4beccf93cf14
+EBUILD mixlib-shellout-2.4.0.ebuild 697 BLAKE2B f559b755c81e4104705897fb5acee2ac22c84951790d41a34c1a2b4d66d881cd9f98359387686ebb8e6a39f402aa925f874490ec0dd39287a7b41a7e1f00aefb SHA512 50e3074f7f767ab17e423c90c5f2dc762c88254044eb2b2e64f66e510b31302085f48a0c74e85691c54d1b164da530fc7c4f292fb9d15e1215efdc79e060c427
MISC metadata.xml 349 BLAKE2B bbf03da0b10552936f124a0d5ef0fc3513b2a381f2101a4f6088cdaf1a1287a6580bbac4247729c725562cfb2181bc4d1e744b1e07a6d8871b334e85d5f55269 SHA512 895846614036d27c1ca678c47d46302985645d1079c16910dfccb1a4077554422c6f08555d3fe3275c6463734d869f160ac1265dc06854db512001e8b05b32c7
diff --git a/dev-ruby/mixlib-shellout/mixlib-shellout-2.4.0.ebuild b/dev-ruby/mixlib-shellout/mixlib-shellout-2.4.0.ebuild
new file mode 100644
index 000000000000..6c6bcd0d579e
--- /dev/null
+++ b/dev-ruby/mixlib-shellout/mixlib-shellout-2.4.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRA_DOC="CHANGELOG.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Run external commands on Unix or Windows"
+HOMEPAGE="https://github.com/opscode/mixlib-shellout"
+SRC_URI="https://github.com/opscode/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+each_ruby_prepare() {
+ # Make sure we actually use the right interpreter for testing
+ sed -i -e "/ruby_eval/ s:ruby :${RUBY} :" spec/mixlib/shellout_spec.rb || die
+}