summaryrefslogtreecommitdiff
path: root/dev-ruby/mixlib-shellout
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/mixlib-shellout
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/mixlib-shellout')
-rw-r--r--dev-ruby/mixlib-shellout/Manifest3
-rw-r--r--dev-ruby/mixlib-shellout/metadata.xml11
-rw-r--r--dev-ruby/mixlib-shellout/mixlib-shellout-2.3.2.ebuild26
3 files changed, 40 insertions, 0 deletions
diff --git a/dev-ruby/mixlib-shellout/Manifest b/dev-ruby/mixlib-shellout/Manifest
new file mode 100644
index 000000000000..26786c1438c9
--- /dev/null
+++ b/dev-ruby/mixlib-shellout/Manifest
@@ -0,0 +1,3 @@
+DIST mixlib-shellout-2.3.2.tar.gz 35828 BLAKE2B 8fa665a0be90da481d2e83aeb0bbfe35be6086cad25cfff5f079f0aa53926318961d2192da3477e4a4cd728e57752f32652579d544f562d81941a3d357c5bb5a SHA512 72f4979d1c444b1f097ecfd4767a2989e60398e84a78106b80077b664bc01d6fc68022cec26172f1e7c0384dd3fc4f64c723ad3a2882db7284dbadacc7cf24c9
+EBUILD mixlib-shellout-2.3.2.ebuild 704 BLAKE2B b14580e6ad10a522475542cdc2f185b82ffeb20f36012b35a04a048678dc3ca9f4fedde9946fdcb67a412c706632a813d7bdec594614c3be04cb00e9adc429a8 SHA512 9fa00797118c24474e0052210ab603bd5b3d9c89829427793c10a38bd8cb4523c271be35dbe681c4f9610eab797404bbcf8502768473d791a73d4beccf93cf14
+MISC metadata.xml 349 BLAKE2B bbf03da0b10552936f124a0d5ef0fc3513b2a381f2101a4f6088cdaf1a1287a6580bbac4247729c725562cfb2181bc4d1e744b1e07a6d8871b334e85d5f55269 SHA512 895846614036d27c1ca678c47d46302985645d1079c16910dfccb1a4077554422c6f08555d3fe3275c6463734d869f160ac1265dc06854db512001e8b05b32c7
diff --git a/dev-ruby/mixlib-shellout/metadata.xml b/dev-ruby/mixlib-shellout/metadata.xml
new file mode 100644
index 000000000000..d4692422af46
--- /dev/null
+++ b/dev-ruby/mixlib-shellout/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">opscode/mixlib-shellout</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/mixlib-shellout/mixlib-shellout-2.3.2.ebuild b/dev-ruby/mixlib-shellout/mixlib-shellout-2.3.2.ebuild
new file mode 100644
index 000000000000..adcdf80bf37e
--- /dev/null
+++ b/dev-ruby/mixlib-shellout/mixlib-shellout-2.3.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby21 ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRA_DOC="CHANGELOG.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Run external commands on Unix or Windows"
+HOMEPAGE="https://github.com/opscode/mixlib-shellout"
+SRC_URI="https://github.com/opscode/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+each_ruby_prepare() {
+ # Make sure we actually use the right interpreter for testing
+ sed -i -e "/ruby_eval/ s:ruby :${RUBY} :" spec/mixlib/shellout_spec.rb || die
+}