summaryrefslogtreecommitdiff
path: root/dev-ruby/mixlib-shellout
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-07-19 22:05:27 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-07-19 22:05:27 +0100
commit121ed4eec41fbf03e1998d09eede1bf449da63b9 (patch)
treece9341d77d1507f67d4a3a1472da9011b5baa0a8 /dev-ruby/mixlib-shellout
parentdd762ff83c330186ee2ede002e08b2f780cddd51 (diff)
gentoo resync : 19.07.2019
Diffstat (limited to 'dev-ruby/mixlib-shellout')
-rw-r--r--dev-ruby/mixlib-shellout/Manifest2
-rw-r--r--dev-ruby/mixlib-shellout/mixlib-shellout-3.0.4.ebuild29
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-ruby/mixlib-shellout/Manifest b/dev-ruby/mixlib-shellout/Manifest
index be645f038e5b..e2742152e97b 100644
--- a/dev-ruby/mixlib-shellout/Manifest
+++ b/dev-ruby/mixlib-shellout/Manifest
@@ -1,3 +1,5 @@
DIST mixlib-shellout-2.4.4.tar.gz 38305 BLAKE2B 19e4211dee056e03f007971d4d77685a2d2d6a111439903bd33e0ed8dee62090b54b6f15e0bc6db168591491c2462869645174a909609b7499bdce251a6ceeef SHA512 e42217a6ced0fb8335cb2df60947168c629d637d280b36fe3d77f47593dc73eda72578b0e9ddf48498e27460cb878764c5dff1b5648a0c7d244c16558d57eef4
+DIST mixlib-shellout-3.0.4.tar.gz 42533 BLAKE2B 4d71cfb2d41120be04613749fd5c0e73d6939fe64410e46285a6f81ec61107b1e658ecc011c032621b433eb15e9ffd42b4f589419ffd8f68b7c5977691e011d1 SHA512 2ed866333874c8c40109de9bb4a1e5a3afea4f4c4cf537b11a1ccd670d374b9ce132717e87d43bb41065a9361e45de13bb1fa2db3e1f2d9f4af18253548f5811
EBUILD mixlib-shellout-2.4.4.ebuild 888 BLAKE2B f10ff7cb63a9c135dadfe842a1fa0e63d8429440579735a0e01386d7e385e83e05a74ed9373fd49be555cc23dbb79bad477537b5c3fb5a9619863b375d6f0498 SHA512 e025185540ccc8afab4c8f549b21fed49e945a79805d3557e52bea855046837eeb95a73f8fe8cb094b30c25a7fe1802f45effb4c3b289f505070c0e8613822f3
+EBUILD mixlib-shellout-3.0.4.ebuild 881 BLAKE2B e53249d636ad6d21d58efe0302cc5795ebd6a08e75df4837717ea2ab1efd144fd19ea71488c4ace3b8d1584e7dfc94300bcc9d106c3f5558e9d006caea16523d SHA512 013042d75f94c5601384d0d7ae7e49de27539668487e5fba3755dcb9c4661caea8d78350979d3a016b4323c202ebb806ba843b65d04913a2e45a695855d54e33
MISC metadata.xml 349 BLAKE2B bbf03da0b10552936f124a0d5ef0fc3513b2a381f2101a4f6088cdaf1a1287a6580bbac4247729c725562cfb2181bc4d1e744b1e07a6d8871b334e85d5f55269 SHA512 895846614036d27c1ca678c47d46302985645d1079c16910dfccb1a4077554422c6f08555d3fe3275c6463734d869f160ac1265dc06854db512001e8b05b32c7
diff --git a/dev-ruby/mixlib-shellout/mixlib-shellout-3.0.4.ebuild b/dev-ruby/mixlib-shellout/mixlib-shellout-3.0.4.ebuild
new file mode 100644
index 000000000000..95d017b5ca3e
--- /dev/null
+++ b/dev-ruby/mixlib-shellout/mixlib-shellout-3.0.4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRA_DOC="CHANGELOG.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Run external commands on Unix or Windows"
+HOMEPAGE="https://github.com/opscode/mixlib-shellout"
+SRC_URI="https://github.com/opscode/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+each_ruby_prepare() {
+ # Make sure we actually use the right interpreter for testing
+ sed -i -e "/ruby_eval/ s:ruby :${RUBY} :" spec/mixlib/shellout_spec.rb || die
+
+ # Avoid spec that requires an interactive terminal
+ sed -i -e '/with subprocess writing lots of data to both stdout and stderr/,/^ end/ s:^:#:' spec/mixlib/shellout_spec.rb || die
+}