summaryrefslogtreecommitdiff
path: root/dev-ruby/method_source
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/method_source
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/method_source')
-rw-r--r--dev-ruby/method_source/Manifest5
-rw-r--r--dev-ruby/method_source/metadata.xml11
-rw-r--r--dev-ruby/method_source/method_source-0.8.2-r3.ebuild25
-rw-r--r--dev-ruby/method_source/method_source-0.9.0.ebuild19
4 files changed, 60 insertions, 0 deletions
diff --git a/dev-ruby/method_source/Manifest b/dev-ruby/method_source/Manifest
new file mode 100644
index 000000000000..da5ce86e17b6
--- /dev/null
+++ b/dev-ruby/method_source/Manifest
@@ -0,0 +1,5 @@
+DIST method_source-0.8.2.gem 13312 BLAKE2B a75b2072d85752eb36715e04c490cecc97f02cee9690748775820dbef5f7577e861b2d22839a8dc834c5fffc04653a0dde92ae01d9cf2d0bbbba78cbf813dc7f SHA512 44cf12bf0e47101f4e91b91b62c54e5403c827be5999b739a930e74c4449861a254631935f6a60430912316767fcc74e3f947075b0b0d994dc864bfdb935af1e
+DIST method_source-0.9.0.gem 13312 BLAKE2B c3d3cd541b782a3e4e2aa2b1576d9206338988330a17e9770e82ff9fc3156f6feff9be970f5f5f0cef90ee160a3dfbbd20c1bac34593906a47daa7404895b08c SHA512 4ef6cdf3f4427a7910f9da8e569d9cc2711de449498fe88ea8782379330a5725a4800168b06fcc593c18faa52294836881852768306303ebc658f97c1bec8830
+EBUILD method_source-0.8.2-r3.ebuild 605 BLAKE2B 3b0c43da31da8a7fbce28a2c0290a063903737962a9affc5390f6b4ecb9e717fa111d8c34391dcff58a289f0344e57b479b50fa884eb4ab1a652636ad2aaa2a7 SHA512 e430a179d0aa81fca4d9398577c2ffcc358312d98fc41e5f5cf50b092bbef78935f3b3183e74525e4eb96cf42b1ae91720bb367849ddaf7ccec5842b31199f2f
+EBUILD method_source-0.9.0.ebuild 478 BLAKE2B 01630b9db733e9573586f94ca393b2ff53303cd19bdffa4490fac69dd872e6242711c517d26fb391aad175869877c83b63aaea06bc750573534b213f3c581bed SHA512 3ec28bf46d6dbd89cb56076eddfd32024f71e3ddaf4a13159066e9da7f7514a1d500b0c6d99070b69a4f7846b233b51512f91fea5520e0acd006de6fa29b54f1
+MISC metadata.xml 348 BLAKE2B 055674d709a654248c63bf20a1867646170cd6b9e2d74cf54b6640ed14b5b0255b2e23986ed068a96412b0c288262fd207d0e267b70f356ee048635732f8a965 SHA512 425721c75e37753f9df91fdc628d1cdad2ab61fb9c49af31405df4070bcf429a703b8696ba5f0a596416f7d7f14ccb4285e39afd15302da6ec753a630d098e88
diff --git a/dev-ruby/method_source/metadata.xml b/dev-ruby/method_source/metadata.xml
new file mode 100644
index 000000000000..336cf6c41d8f
--- /dev/null
+++ b/dev-ruby/method_source/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">banister/method_source</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/method_source/method_source-0.8.2-r3.ebuild b/dev-ruby/method_source/method_source-0.8.2-r3.ebuild
new file mode 100644
index 000000000000..0c1f13b10081
--- /dev/null
+++ b/dev-ruby/method_source/method_source-0.8.2-r3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby21 ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_TASK_TEST="none"
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.markdown"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Retrieve the source code for a method"
+HOMEPAGE="https://github.com/banister/method_source"
+IUSE=""
+SLOT="0"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+
+ruby_add_bdepend "test? ( >=dev-ruby/bacon-1.1.0 )"
+
+each_ruby_test() {
+ ${RUBY} -I. -S bacon -k test/test.rb || die "Tests failed."
+}
diff --git a/dev-ruby/method_source/method_source-0.9.0.ebuild b/dev-ruby/method_source/method_source-0.9.0.ebuild
new file mode 100644
index 000000000000..67e956a364a1
--- /dev/null
+++ b/dev-ruby/method_source/method_source-0.9.0.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby22 ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.markdown"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Retrieve the source code for a method"
+HOMEPAGE="https://github.com/banister/method_source"
+IUSE=""
+SLOT="0"
+
+LICENSE="MIT"
+KEYWORDS="amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"