summaryrefslogtreecommitdiff
path: root/dev-ruby/metasm/metasm-1.0.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-06-02 21:45:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-06-02 21:45:28 +0100
commit2018227e9344edb9da15fc6a4a8298086cc2aa77 (patch)
treec18e1c09e605e94e2a1e93345ad25746cc9e14b9 /dev-ruby/metasm/metasm-1.0.4.ebuild
parent6f8038813c460b4f0572d5ef595cdfa94af3a94d (diff)
gentoo resync : 02.06.2019
Diffstat (limited to 'dev-ruby/metasm/metasm-1.0.4.ebuild')
-rw-r--r--dev-ruby/metasm/metasm-1.0.4.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-ruby/metasm/metasm-1.0.4.ebuild b/dev-ruby/metasm/metasm-1.0.4.ebuild
new file mode 100644
index 000000000000..c8698af680ca
--- /dev/null
+++ b/dev-ruby/metasm/metasm-1.0.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_RECIPE_DOC="none"
+RUBY_FAKEGEM_EXTRADOC="BUGS README TODO"
+RUBY_FAKEGEM_EXTRAINSTALL="metasm metasm.rb misc samples"
+
+inherit ruby-fakegem
+
+DESCRIPTION="cross-architecture assembler, disassembler, linker, and debugger"
+HOMEPAGE="https://metasm.cr0.org/"
+
+LICENSE="LGPL-2.1"
+SLOT="${PV}"
+IUSE=""
+
+KEYWORDS="~amd64 ~arm ~x86"
+
+all_ruby_prepare() {
+ mkdir bin
+ ln -s ../samples/disassemble.rb ./bin/disassemble
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ ruby_fakegem_binwrapper disassemble
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:. -e "Dir['tests/*.rb'].each{|f| require f}" || die
+}