summaryrefslogtreecommitdiff
path: root/dev-ruby/memo_wise/memo_wise-1.7.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
commite68d405c5d712af4387159df07e226217bdda049 (patch)
tree009ab0f3d427f0813e62930d71802cb054c07e30 /dev-ruby/memo_wise/memo_wise-1.7.0.ebuild
parent401101f9c8077911929d3f2b60a37098460a5d89 (diff)
gentoo resync : 06.04.2022
Diffstat (limited to 'dev-ruby/memo_wise/memo_wise-1.7.0.ebuild')
-rw-r--r--dev-ruby/memo_wise/memo_wise-1.7.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-ruby/memo_wise/memo_wise-1.7.0.ebuild b/dev-ruby/memo_wise/memo_wise-1.7.0.ebuild
new file mode 100644
index 000000000000..607af09f1301
--- /dev/null
+++ b/dev-ruby/memo_wise/memo_wise-1.7.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby26 ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+RUBY_FAKEGEM_GEMSPEC="memo_wise.gemspec"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="The wise choice for Ruby memoization"
+HOMEPAGE="https://github.com/panorama-ed/memo_wise"
+SRC_URI="https://github.com/panorama-ed/memo_wise/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/ s:^:#:' spec/spec_helper.rb || die
+
+ # Avoid specs for an unmaintained package with old dependencies that is optional.
+ sed -e '/require.*values/ s:^:#:' \
+ -e '/when the class is a Value class/,/^ end/ s:^:#:' \
+ -i spec/memo_wise_spec.rb || die
+
+ sed -e 's:_relative ": "./:' \
+ -e 's/__dir__/"."/' \
+ -e 's/git ls-files -z/find * -print0/' \
+ -i ${RUBY_FAKEGEM_GEMSPEC} || die
+}