summaryrefslogtreecommitdiff
path: root/dev-ruby/maxitest
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/maxitest
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/maxitest')
-rw-r--r--dev-ruby/maxitest/Manifest7
-rw-r--r--dev-ruby/maxitest/maxitest-2.8.0.ebuild48
-rw-r--r--dev-ruby/maxitest/maxitest-3.0.1.ebuild48
-rw-r--r--dev-ruby/maxitest/maxitest-3.1.0.ebuild48
-rw-r--r--dev-ruby/maxitest/metadata.xml11
5 files changed, 162 insertions, 0 deletions
diff --git a/dev-ruby/maxitest/Manifest b/dev-ruby/maxitest/Manifest
new file mode 100644
index 000000000000..bb73a4c8970b
--- /dev/null
+++ b/dev-ruby/maxitest/Manifest
@@ -0,0 +1,7 @@
+DIST maxitest-2.8.0.tar.gz 60742 BLAKE2B 313e7efeca866961f3ee4c43279557bf628bd5d6d75e119fc9723b16a4dc7d38784a34078a9c6c6c5893f4bd28723757658122794deeca70f1abf54187819acf SHA512 cf05087052bb9162d20cca5180808edc00606d0125d461968c033cc4ee44a193d45a337fa2d61f34e8c2097d71bad5eba16da6cf10166ee8afaacda29654ab89
+DIST maxitest-3.0.1.tar.gz 60926 BLAKE2B 9ef03af6e55e7565acfa89d64e04aab40ef11445f0266ee85e68daa7224000922b8107c72cf77e75c4ba630ec19207cab3f5b0ce08f42270756deabfa5124b28 SHA512 c71e8af37387a8dd8f73aa01cde1c5baf772a7fe6125df5962ffb1aaf07515ebcd6d0f8530f306cc60927a289f21e4c75e0fece674230d8cdab82f5bfecfb899
+DIST maxitest-3.1.0.tar.gz 60956 BLAKE2B 5819137a548dfe1ae1c641ea3ddb4fbdf522e08b35eddbeb5dd4f3cfe2f320d16779d48166be820215e3dedecbe1f77d2db475403d476e53d5019631a0972d09 SHA512 37fdba5658cd640de311efaaa50ca32b9415c0819b9adc919d6471ae9317f9a60eb5004afa29d67386b6b9524bda06791054b1d34e31ccbe160a56c315f44b76
+EBUILD maxitest-2.8.0.ebuild 1320 BLAKE2B dfc9156672e8da6105f8b0ffe97c99b144b785e7638e3d31c80a58c8f9e8d158c55e160b6bba4933145f0402334d533fb60ec249726d47e7c8afdb82693d25a5 SHA512 326bd8314fd511ed80684b55996cadcd745344163169a1f5a025682b538679b9f31e4f3b5bf6f6bea4c04427285c6292f03518c28f5b1112659b5be7fe2a7618
+EBUILD maxitest-3.0.1.ebuild 1314 BLAKE2B df8c3bc52a80394b51af34f412e419e715b2d40fb13a43f660c125eb78553a675948abe6928c96b7db7488508be3e22240038fe2cff42e28a741ff80e1153f56 SHA512 cfc7e19b333dcf409c7166ad7dc72364e16c7fa5e61d806010712342aea824805a4cbd0bd72d21bff50137ac9c63fd2b8cf9e9d54becaa0a8d6070a8f0f32d11
+EBUILD maxitest-3.1.0.ebuild 1314 BLAKE2B df8c3bc52a80394b51af34f412e419e715b2d40fb13a43f660c125eb78553a675948abe6928c96b7db7488508be3e22240038fe2cff42e28a741ff80e1153f56 SHA512 cfc7e19b333dcf409c7166ad7dc72364e16c7fa5e61d806010712342aea824805a4cbd0bd72d21bff50137ac9c63fd2b8cf9e9d54becaa0a8d6070a8f0f32d11
+MISC metadata.xml 332 BLAKE2B cdef4488ce14b1d8addc2b3f23fa74aa64022d4ed2dfea7a84c85122e357806dd3a466ec2f4fb0fd486373055a78ae579c0f68c90a22b8940499e1ae29c29ded SHA512 ad86da72b8bc8895b0e09bc9e435eefec9ca1738e8b34aceaa959b2431b35c2732c704bd68a02d02c3c88912c20395f8601e2d42ec26f5d15c064893c0ceff0e
diff --git a/dev-ruby/maxitest/maxitest-2.8.0.ebuild b/dev-ruby/maxitest/maxitest-2.8.0.ebuild
new file mode 100644
index 000000000000..5cae59d39770
--- /dev/null
+++ b/dev-ruby/maxitest/maxitest-2.8.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby22 ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="Readme.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit versionator ruby-fakegem
+
+DESCRIPTION="Minitest + all the features you always wanted"
+HOMEPAGE="https://github.com/grosser/maxitest"
+SRC_URI="https://github.com/grosser/maxitest/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="1"
+KEYWORDS="amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend "<dev-ruby/minitest-5.12:5"
+
+ruby_add_bdepend "test? ( dev-ruby/bundler )"
+
+all_ruby_prepare() {
+ rm -f Gemfile.lock || die
+ # Remove developer-only gems from the gemspec and avoid git issues
+ sed -i -e '/\(bump\|wwtd\)/ s:^:#:' \
+ -e 's/git ls-files/find/' \
+ ${RUBY_FAKEGEM_GEMSPEC} || die
+ sed -i -e '/byebug/ s:^:#:' Gemfile || die
+
+}
+
+each_ruby_prepare() {
+ # Use the correct target
+ sed -i -e '/sh/ s:ruby:'${RUBY}':' \
+ -e '/sh/ s:mtest:'${RUBY}' -S mtest:' \
+ spec/maxitest_spec.rb || die
+}
+
+each_ruby_test() {
+ PATH="${S}/bin:${PATH}" RSPEC_VERSION=3 ruby-ng_rspec spec
+}
diff --git a/dev-ruby/maxitest/maxitest-3.0.1.ebuild b/dev-ruby/maxitest/maxitest-3.0.1.ebuild
new file mode 100644
index 000000000000..e82293c8bdc0
--- /dev/null
+++ b/dev-ruby/maxitest/maxitest-3.0.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="Readme.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit versionator ruby-fakegem
+
+DESCRIPTION="Minitest + all the features you always wanted"
+HOMEPAGE="https://github.com/grosser/maxitest"
+SRC_URI="https://github.com/grosser/maxitest/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="1"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend "<dev-ruby/minitest-5.12:5"
+
+ruby_add_bdepend "test? ( dev-ruby/bundler )"
+
+all_ruby_prepare() {
+ rm -f Gemfile.lock || die
+ # Remove developer-only gems from the gemspec and avoid git issues
+ sed -i -e '/\(bump\|wwtd\)/ s:^:#:' \
+ -e 's/git ls-files/find/' \
+ ${RUBY_FAKEGEM_GEMSPEC} || die
+ sed -i -e '/byebug/ s:^:#:' Gemfile || die
+
+}
+
+each_ruby_prepare() {
+ # Use the correct target
+ sed -i -e '/sh/ s:ruby:'${RUBY}':' \
+ -e '/sh/ s:mtest:'${RUBY}' -S mtest:' \
+ spec/maxitest_spec.rb || die
+}
+
+each_ruby_test() {
+ PATH="${S}/bin:${PATH}" RSPEC_VERSION=3 ruby-ng_rspec spec
+}
diff --git a/dev-ruby/maxitest/maxitest-3.1.0.ebuild b/dev-ruby/maxitest/maxitest-3.1.0.ebuild
new file mode 100644
index 000000000000..e82293c8bdc0
--- /dev/null
+++ b/dev-ruby/maxitest/maxitest-3.1.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="Readme.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit versionator ruby-fakegem
+
+DESCRIPTION="Minitest + all the features you always wanted"
+HOMEPAGE="https://github.com/grosser/maxitest"
+SRC_URI="https://github.com/grosser/maxitest/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="1"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend "<dev-ruby/minitest-5.12:5"
+
+ruby_add_bdepend "test? ( dev-ruby/bundler )"
+
+all_ruby_prepare() {
+ rm -f Gemfile.lock || die
+ # Remove developer-only gems from the gemspec and avoid git issues
+ sed -i -e '/\(bump\|wwtd\)/ s:^:#:' \
+ -e 's/git ls-files/find/' \
+ ${RUBY_FAKEGEM_GEMSPEC} || die
+ sed -i -e '/byebug/ s:^:#:' Gemfile || die
+
+}
+
+each_ruby_prepare() {
+ # Use the correct target
+ sed -i -e '/sh/ s:ruby:'${RUBY}':' \
+ -e '/sh/ s:mtest:'${RUBY}' -S mtest:' \
+ spec/maxitest_spec.rb || die
+}
+
+each_ruby_test() {
+ PATH="${S}/bin:${PATH}" RSPEC_VERSION=3 ruby-ng_rspec spec
+}
diff --git a/dev-ruby/maxitest/metadata.xml b/dev-ruby/maxitest/metadata.xml
new file mode 100644
index 000000000000..53f6755680eb
--- /dev/null
+++ b/dev-ruby/maxitest/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">grosser/maxitest</remote-id>
+ </upstream>
+</pkgmetadata>