summaryrefslogtreecommitdiff
path: root/dev-ruby/maxitest/maxitest-3.3.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-09-13 17:49:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-09-13 17:49:31 +0100
commit36ac65103bf5503e5bad1ecc7e8cb9e7643f6840 (patch)
treed9d1fbc20509d4c90f57fb2d9e1459bc8034c831 /dev-ruby/maxitest/maxitest-3.3.0.ebuild
parenta1392efe64137262023d92492396ca9156d22396 (diff)
Revert "gentoo resync : 13.09.2019"
This reverts commit a1392efe64137262023d92492396ca9156d22396.
Diffstat (limited to 'dev-ruby/maxitest/maxitest-3.3.0.ebuild')
-rw-r--r--dev-ruby/maxitest/maxitest-3.3.0.ebuild47
1 files changed, 0 insertions, 47 deletions
diff --git a/dev-ruby/maxitest/maxitest-3.3.0.ebuild b/dev-ruby/maxitest/maxitest-3.3.0.ebuild
deleted file mode 100644
index 55dcc6eb545a..000000000000
--- a/dev-ruby/maxitest/maxitest-3.3.0.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-USE_RUBY="ruby24 ruby25 ruby26"
-
-RUBY_FAKEGEM_EXTRADOC="Readme.md"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-
-RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Minitest + all the features you always wanted"
-HOMEPAGE="https://github.com/grosser/maxitest"
-SRC_URI="https://github.com/grosser/maxitest/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="1"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-ruby_add_rdepend "<dev-ruby/minitest-5.12:5"
-
-ruby_add_bdepend "test? ( dev-ruby/bundler )"
-
-all_ruby_prepare() {
- rm -f Gemfile.lock || die
- # Remove developer-only gems from the gemspec and avoid git issues
- sed -i -e '/\(bump\|wwtd\)/ s:^:#:' \
- -e 's/git ls-files/find/' \
- ${RUBY_FAKEGEM_GEMSPEC} || die
- sed -i -e '/byebug/ s:^:#:' Gemfile || die
-
-}
-
-each_ruby_prepare() {
- # Use the correct target
- sed -i -e '/sh/ s:ruby:'${RUBY}':' \
- -e '/sh/ s:mtest:'${RUBY}' -S mtest:' \
- spec/maxitest_spec.rb || die
-}
-
-each_ruby_test() {
- PATH="${S}/bin:${PATH}" RSPEC_VERSION=3 ruby-ng_rspec spec
-}