summaryrefslogtreecommitdiff
path: root/dev-ruby/maruku
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/maruku
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/maruku')
-rw-r--r--dev-ruby/maruku/Manifest5
-rw-r--r--dev-ruby/maruku/maruku-0.7.2-r1.ebuild42
-rw-r--r--dev-ruby/maruku/maruku-0.7.3.ebuild42
-rw-r--r--dev-ruby/maruku/metadata.xml14
4 files changed, 103 insertions, 0 deletions
diff --git a/dev-ruby/maruku/Manifest b/dev-ruby/maruku/Manifest
new file mode 100644
index 000000000000..a78335b544b9
--- /dev/null
+++ b/dev-ruby/maruku/Manifest
@@ -0,0 +1,5 @@
+DIST maruku-0.7.2.gem 142336 BLAKE2B 54b65ae0db7d7b6f97521408b056ce520382fb9fa5ec8c9c74806ac31ec9f2dbe7af3a366fa962147d47c28e58289839b62c515d5b767481b9e13a2b3140a96a SHA512 45eaec7ba721499acbfed97cac4eddfe50c2200a70394e06dc6dd4c6c642b0c58d126c48dabfc4b9697423dd99ecf8691e223125a44d59a382a76e051f2af622
+DIST maruku-0.7.3.gem 140288 BLAKE2B 31da6bf63272a2e5a77aa6f3cdc1462f0039751424bd0888d69f2f2660534cab8868238cbde37d184c2ddbe50b76dbfa5305a450fc27b9995f74284a1f962724 SHA512 efef3eea7451e32c06c0820834cb98eb5424f6837b2e66e44482679d73d958e1e2c59e790a3e5ba26e0c91ece0a5c17f91877a7797d9a15a73b5344b0d444507
+EBUILD maruku-0.7.2-r1.ebuild 1242 BLAKE2B 9a68041c9ae854021b70b4bdb91801d95e71e23bb270f163fccc9d560e3c3a8210b07a7fd148fc993937499cff3c5a636e6b903e8fc9a475529090b60fc3d412 SHA512 f129257e9206c59112dcc28aa4b6b95118b43b63ea732eec7294745a0fc376cee8627e9ee42c38e80025c9cbd5f2d883e98dd70c4faab179c4667a3c0e2b7c6b
+EBUILD maruku-0.7.3.ebuild 1258 BLAKE2B 0864918b72e8f123c9277d78454526c12ad9aa4aeb63b6e79efb5d74d454afbe52f5dc08780eb9c7646659a2c7edbd18d17b0e017a5e540ae61e987bfb0f46e4 SHA512 2c25cc6941caa6d8aeee193b63424e18bd1a442ef268c5383637699c35249d2cee6ea769ec3f92a56e6071af20193d2cb9afd0327fd31e78b640f011e28df23f
+MISC metadata.xml 454 BLAKE2B 543ededb4beb16959617c700295d7c7517c3969b482ee0e0ea71cab8c412ba09480b4503024dc23d1f419c9bc621a66cc23a589d240577554a36a712f4d1892e SHA512 b58d0a08843b11dd0ce0fc68d347f16aa2e6fd6530a3f7a54ece40c6076cc64544857081d9ff889a816ac545e68973f709c168378fdd756bca286e4b874a2084
diff --git a/dev-ruby/maruku/maruku-0.7.2-r1.ebuild b/dev-ruby/maruku/maruku-0.7.2-r1.ebuild
new file mode 100644
index 000000000000..833899f2a194
--- /dev/null
+++ b/dev-ruby/maruku/maruku-0.7.2-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+USE_RUBY="ruby22 ruby23"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="docs/div_syntax.md docs/entity_test.md
+ docs/markdown_syntax.md docs/maruku.md docs/math.md docs/other_stuff.md
+ docs/proposal.md"
+RUBY_FAKEGEM_EXTRAINSTALL="data"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Markdown-superset interpreter written in Ruby"
+HOMEPAGE="https://github.com/bhollis/maruku"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 arm ~hppa ppc ppc64 x86 ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="highlight test"
+
+ruby_add_bdepend "test? ( dev-ruby/nokogiri-diff )"
+ruby_add_rdepend "highlight? ( dev-ruby/syntax )"
+
+DEPEND+=" test? ( app-text/blahtexml )"
+
+all_ruby_prepare() {
+ sed -i -e '/[Ss]imple[Cc]ov/ s:^:#:' spec/spec_helper.rb || die
+}
+
+pkg_postinst() {
+ elog
+ elog "You need to emerge app-text/texlive and dev-texlive/texlive-latexextra if"
+ elog "you want to use --pdf with Maruku. You may also want to emerge"
+ elog "dev-texlive/texlive-latexrecommended to enable LaTeX syntax highlighting."
+ elog
+}
diff --git a/dev-ruby/maruku/maruku-0.7.3.ebuild b/dev-ruby/maruku/maruku-0.7.3.ebuild
new file mode 100644
index 000000000000..f58ea3aa540e
--- /dev/null
+++ b/dev-ruby/maruku/maruku-0.7.3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="docs/div_syntax.md docs/entity_test.md
+ docs/markdown_syntax.md docs/maruku.md docs/math.md docs/other_stuff.md
+ docs/proposal.md"
+RUBY_FAKEGEM_EXTRAINSTALL="data"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Markdown-superset interpreter written in Ruby"
+HOMEPAGE="https://github.com/bhollis/maruku"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~arm64 ~hppa ~ppc ppc64 x86 ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="highlight test"
+
+ruby_add_bdepend "test? ( dev-ruby/nokogiri-diff )"
+ruby_add_rdepend "highlight? ( dev-ruby/syntax )"
+
+DEPEND+=" test? ( app-text/blahtexml )"
+
+all_ruby_prepare() {
+ sed -i -e '/[Ss]imple[Cc]ov/ s:^:#:' spec/spec_helper.rb || die
+}
+
+pkg_postinst() {
+ elog
+ elog "You need to emerge app-text/texlive and dev-texlive/texlive-latexextra if"
+ elog "you want to use --pdf with Maruku. You may also want to emerge"
+ elog "dev-texlive/texlive-latexrecommended to enable LaTeX syntax highlighting."
+ elog
+}
diff --git a/dev-ruby/maruku/metadata.xml b/dev-ruby/maruku/metadata.xml
new file mode 100644
index 000000000000..81fd3736f4e8
--- /dev/null
+++ b/dev-ruby/maruku/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <use>
+ <flag name="highlight">Enable source code highlighting via <pkg>dev-ruby/syntax</pkg></flag>
+ </use>
+ <upstream>
+ <remote-id type="github">bhollis/maruku</remote-id>
+ </upstream>
+</pkgmetadata>