summaryrefslogtreecommitdiff
path: root/dev-ruby/maildir
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/maildir
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/maildir')
-rw-r--r--dev-ruby/maildir/Manifest3
-rw-r--r--dev-ruby/maildir/maildir-2.2.1-r1.ebuild33
-rw-r--r--dev-ruby/maildir/metadata.xml11
3 files changed, 47 insertions, 0 deletions
diff --git a/dev-ruby/maildir/Manifest b/dev-ruby/maildir/Manifest
new file mode 100644
index 000000000000..acd9865f9954
--- /dev/null
+++ b/dev-ruby/maildir/Manifest
@@ -0,0 +1,3 @@
+DIST maildir-2.2.1.gem 15360 BLAKE2B d3ea037ba38e83bc7b21bde9ccb2296fc922c3f657a73ad3637faf708cfa16ac75c2e6535714ba18b00aafc5a94265c56f6e086d25de5810c0a0112d6c876e1f SHA512 4c366333c802bbe0cbd19e6abaef1fa31ad84596518d24ddcc33aa3afe39890896d107bc864c68787c90c3a38115979f6a4fe8b442aecaead39306122d560f18
+EBUILD maildir-2.2.1-r1.ebuild 961 BLAKE2B cdc5aa265df7cc7111587a7196e1a2225a6723619ad28646d409a0f775d2bb4a126b396aafc20fedcfcaf0c6fde1d2693ac569e02f22e05b98efda8f17d7c4fe SHA512 c1d4d90d6b83e00c1b0cd9bfebc136ec6407a4e975708acc589ef87302a18e1ccae497e34fb90c78a991f8220da7d4f8ce052bc8975bdc475e9263ae4848ed77
+MISC metadata.xml 341 BLAKE2B 6081100c628ae44a08e012674babbb174a563ffc3c9239bb4dc117e372af60d23a68f8666b4f79c2a17c0270a8df39efc0106a07bacf600b76b5d85dfe9facc3 SHA512 68ef596ba601b4886488bf164b786fc0deaca4a10441ac164bd6eef0502c12e380ca27215f6599660467fafcfc3b6183fb7ae0dd847888aa8919437896e6119b
diff --git a/dev-ruby/maildir/maildir-2.2.1-r1.ebuild b/dev-ruby/maildir/maildir-2.2.1-r1.ebuild
new file mode 100644
index 000000000000..58a9690259b9
--- /dev/null
+++ b/dev-ruby/maildir/maildir-2.2.1-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+RUBY_FAKEGEM_EXTRAINSTALL="README.rdoc"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="A library for reading and writing arbitrary messages in DJB's maildir format"
+HOMEPAGE="https://github.com/ktheory/maildir"
+LICENSE="MIT"
+
+KEYWORDS="~amd64"
+SLOT="2"
+IUSE="test"
+
+ruby_add_bdepend "
+ test? ( >=dev-ruby/fakefs-0.3.2 dev-ruby/mail dev-ruby/shoulda-context dev-ruby/test-unit:2 )"
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/ s:^:#:' Rakefile test/helper.rb || die
+ sed -i -e 's/shoulda/shoulda-context/' test/helper.rb || die
+
+ # Avoid tests that appear to need activesupport for .blank? support
+ sed -i -e '/add and remove flags/,/^ end/ s:^:#:' test/test_message.rb || die
+ sed -i -e '/be removed from flag list/,/^ end/ s:^:#:' test/test_maildir.rb || die
+}
diff --git a/dev-ruby/maildir/metadata.xml b/dev-ruby/maildir/metadata.xml
new file mode 100644
index 000000000000..524f23aed803
--- /dev/null
+++ b/dev-ruby/maildir/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ktheory/maildir</remote-id>
+ </upstream>
+</pkgmetadata>