summaryrefslogtreecommitdiff
path: root/dev-ruby/magic/magic-0.2.9-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /dev-ruby/magic/magic-0.2.9-r2.ebuild
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'dev-ruby/magic/magic-0.2.9-r2.ebuild')
-rw-r--r--dev-ruby/magic/magic-0.2.9-r2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-ruby/magic/magic-0.2.9-r2.ebuild b/dev-ruby/magic/magic-0.2.9-r2.ebuild
new file mode 100644
index 000000000000..0640c4315f96
--- /dev/null
+++ b/dev-ruby/magic/magic-0.2.9-r2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby26 ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_EXTRADOC="README.rdoc"
+RUBY_FAKEGEM_GEMSPEC="magic.gemspec"
+RUBY_FAKEGEM_RECIPE_TEST="none"
+
+inherit ruby-fakegem
+
+SRC_URI="https://github.com/qoobaa/magic/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+DESCRIPTION="Ruby FFI bindings to libmagic"
+HOMEPAGE="https://github.com/qoobaa/magic"
+
+IUSE="test"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND+="sys-apps/file"
+DEPEND+="test? ( sys-apps/file )"
+
+ruby_add_bdepend "test? ( dev-ruby/test-unit:2 )"
+ruby_add_rdepend "dev-ruby/ffi"
+
+all_ruby_prepare() {
+ sed -i -e 's/git ls-files -z/find * -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib -Itest test/test_magic.rb || die
+}