summaryrefslogtreecommitdiff
path: root/dev-ruby/loquacious/loquacious-1.9.1-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ruby/loquacious/loquacious-1.9.1-r2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ruby/loquacious/loquacious-1.9.1-r2.ebuild')
-rw-r--r--dev-ruby/loquacious/loquacious-1.9.1-r2.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-ruby/loquacious/loquacious-1.9.1-r2.ebuild b/dev-ruby/loquacious/loquacious-1.9.1-r2.ebuild
new file mode 100644
index 000000000000..445d1b99a150
--- /dev/null
+++ b/dev-ruby/loquacious/loquacious-1.9.1-r2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+USE_RUBY="ruby21 ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR="doc"
+
+RUBY_FAKEGEM_EXTRADOC="History.txt README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Descriptive configuration files for Ruby written in Ruby"
+HOMEPAGE="https://github.com/TwP/loquacious"
+
+IUSE=""
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+all_ruby_prepare() {
+ # Remove metadata because it confuses jruby.
+ rm -f ../metadata || die
+}
+
+all_ruby_compile() {
+ if use doc; then
+ rdoc lib || die "Documentation generation failed."
+ fi
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ docinto examples
+ dodoc examples/*
+}