summaryrefslogtreecommitdiff
path: root/dev-ruby/loofah/loofah-2.19.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-01 13:10:51 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-01 13:10:51 +0100
commit8598ab9ad325d12d0f2901ecc0973e430dacd2b3 (patch)
tree593f226746c1f850f57bc10ffc81f7398d5a34f0 /dev-ruby/loofah/loofah-2.19.0.ebuild
parent42ff81a7480d9bba317b42fcca03b46da2a622ce (diff)
gentoo auto-resync : 01:10:2022 - 13:10:50
Diffstat (limited to 'dev-ruby/loofah/loofah-2.19.0.ebuild')
-rw-r--r--dev-ruby/loofah/loofah-2.19.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-ruby/loofah/loofah-2.19.0.ebuild b/dev-ruby/loofah/loofah-2.19.0.ebuild
new file mode 100644
index 000000000000..16fcec1713d7
--- /dev/null
+++ b/dev-ruby/loofah/loofah-2.19.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="loofah.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Library for manipulating and transforming HTML/XML documents and fragments."
+HOMEPAGE="https://github.com/flavorjones/loofah"
+SRC_URI="https://github.com/flavorjones/loofah/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux"
+IUSE=""
+
+ruby_add_rdepend "=dev-ruby/crass-1.0* >=dev-ruby/crass-1.0.2 >=dev-ruby/nokogiri-1.5.9"
+
+ruby_add_bdepend "test? ( >=dev-ruby/rr-1.1.0 )"
+
+all_ruby_prepare() {
+ # Fix version in gemspec
+ sed -i -e '/s\.version/ s/".*"/"'${PV}'"/' ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ # Avoid unneeded development dependencies
+ sed -i -e '/concourse/I s:^:#:' Rakefile || die
+
+ # Avoid test failing on different whitespace.
+ sed -i -e '/test_fragment_whitewash_on_microsofty_markup/askip "gentoo"' test/integration/test_ad_hoc.rb || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:.:test -e 'Dir["test/**/test_*.rb"].each{|f| require f}' || die
+}