summaryrefslogtreecommitdiff
path: root/dev-ruby/log4r/log4r-1.1.10-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/log4r/log4r-1.1.10-r2.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/log4r/log4r-1.1.10-r2.ebuild')
-rw-r--r--dev-ruby/log4r/log4r-1.1.10-r2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/log4r/log4r-1.1.10-r2.ebuild b/dev-ruby/log4r/log4r-1.1.10-r2.ebuild
new file mode 100644
index 000000000000..37fe6a5eb66b
--- /dev/null
+++ b/dev-ruby/log4r/log4r-1.1.10-r2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+# There are no working tests atm, to be checked on next version bump.
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_DOCDIR="doc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A comprehensive and flexible logging library written in Ruby"
+HOMEPAGE="http://log4r.sourceforge.net/"
+IUSE=""
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~hppa ia64 ppc ppc64 ~sparc x86"
+
+all_ruby_install() {
+ all_fakegem_install
+
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+}