summaryrefslogtreecommitdiff
path: root/dev-ruby/log4r/log4r-1.1.10-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ruby/log4r/log4r-1.1.10-r2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ruby/log4r/log4r-1.1.10-r2.ebuild')
-rw-r--r--dev-ruby/log4r/log4r-1.1.10-r2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/log4r/log4r-1.1.10-r2.ebuild b/dev-ruby/log4r/log4r-1.1.10-r2.ebuild
new file mode 100644
index 000000000000..93d490ea9959
--- /dev/null
+++ b/dev-ruby/log4r/log4r-1.1.10-r2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby21 ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+# There are no working tests atm, to be checked on next version bump.
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_DOCDIR="doc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A comprehensive and flexible logging library written in Ruby"
+HOMEPAGE="http://log4r.sourceforge.net/"
+IUSE=""
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ia64 ppc ppc64 ~sparc x86"
+
+all_ruby_install() {
+ all_fakegem_install
+
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+}