summaryrefslogtreecommitdiff
path: root/dev-ruby/localhost
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-11-13 13:10:00 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-11-13 13:10:00 +0000
commite9d044d4b9b71200a96adfa280848858c0f468c9 (patch)
tree1bd8ef816043a8cd340f1d774e79553a1a7d31d8 /dev-ruby/localhost
parentfc2f1018fc323ef2c6572734a9b130427cba76a6 (diff)
gentoo resync : 13.11.2021
Diffstat (limited to 'dev-ruby/localhost')
-rw-r--r--dev-ruby/localhost/Manifest3
-rw-r--r--dev-ruby/localhost/localhost-1.1.9.ebuild31
-rw-r--r--dev-ruby/localhost/metadata.xml8
3 files changed, 42 insertions, 0 deletions
diff --git a/dev-ruby/localhost/Manifest b/dev-ruby/localhost/Manifest
new file mode 100644
index 000000000000..8248c4308813
--- /dev/null
+++ b/dev-ruby/localhost/Manifest
@@ -0,0 +1,3 @@
+DIST localhost-1.1.9.tar.gz 2125545 BLAKE2B 5843b3857a11d9f56412f67cb15e424332b07cf81a29ae0a05a3ff20c6f06af56f6a02d8315f97c2d57fe76f7359c737cf19f116868ff532ac083070430fa22e SHA512 d46fd016957fd34309d50488dc61f23e9d47a5a6bfdeda5c049f6ffc112c13cd21394ada3e15c56f14913cba6ab503f60e32237431f7ff824fbbab8cd8a2d746
+EBUILD localhost-1.1.9.ebuild 881 BLAKE2B ea6edc7a456444f2e4c95286ba9fe0a243698f6f13b746484c9637016b6adb7d329ac9efce7650205f00b263cfd725838d41f87a039038ae7e7554b60c311f35 SHA512 3d31e6135de9ff67c7a7b4240ad50f97c3bb3d36a51e6b98951dcb35d577d00705fda8bc6dd2412ff6426c8ce6e8f3e01a896ac51711f993a6d2422427124c8f
+MISC metadata.xml 248 BLAKE2B 0c876bde3c72e61d28284a95a837103e6d594c9f6fccbd6d7d1039f9c5a604347c20c334c9a57d80b152888fed536196f2807b477e8d0336c80affb0e28c9dc9 SHA512 b2b64178cf6cbbaa5fb4671ffe1ab88b83c920de363ae099ef74fa3e5eb8c8f0285c749cabc0cebf344951503d1b7309ae294afe9e7cf5172700182d8843fa14
diff --git a/dev-ruby/localhost/localhost-1.1.9.ebuild b/dev-ruby/localhost/localhost-1.1.9.ebuild
new file mode 100644
index 000000000000..ad7d1838dce5
--- /dev/null
+++ b/dev-ruby/localhost/localhost-1.1.9.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_GEMSPEC="localhost.gemspec"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Manage a local CA for self-signed localhost development servers"
+HOMEPAGE="https://github.com/socketry/localhost"
+SRC_URI="https://github.com/socketry/localhost/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="MIT"
+
+KEYWORDS="~amd64 ~sparc ~x86"
+SLOT="$(ver_cut 1)"
+IUSE=""
+
+# Skip tests for now since they require a lot of
+# dependencies and this package blocks a security bug.
+RESTRICT="test"
+
+#ruby_add_bdepend "test? ( dev-ruby/async-rspec ) "
+
+all_ruby_prepare() {
+ sed -i -e 's:_relative ": "./:' ${RUBY_FAKEGEM_GEMSPEC} || die
+ sed -i -e '/covered/ s:^:#:' spec/spec_helper.rb || die
+}
diff --git a/dev-ruby/localhost/metadata.xml b/dev-ruby/localhost/metadata.xml
new file mode 100644
index 000000000000..658c72b1920d
--- /dev/null
+++ b/dev-ruby/localhost/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+</maintainer>
+</pkgmetadata>