summaryrefslogtreecommitdiff
path: root/dev-ruby/listen/listen-1.3.1-r4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ruby/listen/listen-1.3.1-r4.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ruby/listen/listen-1.3.1-r4.ebuild')
-rw-r--r--dev-ruby/listen/listen-1.3.1-r4.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-ruby/listen/listen-1.3.1-r4.ebuild b/dev-ruby/listen/listen-1.3.1-r4.ebuild
new file mode 100644
index 000000000000..4febe6820910
--- /dev/null
+++ b/dev-ruby/listen/listen-1.3.1-r4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+USE_RUBY="ruby21 ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Listens to file modifications and notifies you about the changes"
+HOMEPAGE="https://github.com/guard/listen"
+SRC_URI="https://github.com/guard/listen/archive/v${PV}.tar.gz -> ${P}-git.tgz"
+
+LICENSE="MIT"
+SLOT="1"
+KEYWORDS="amd64 arm ~arm64 ppc ppc64 x86 ~amd64-linux ~x64-macos"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/rb-inotify-0.9.0"
+
+all_ruby_prepare() {
+ sed -i -e '/[Cc]overalls/d' spec/spec_helper.rb || die
+ # Drop failing test
+ sed -i -e '/#85/,+17d' spec/listen/directory_record_spec.rb || die
+
+ # Drop dependencies for file system events not available on Gentoo.
+ sed -i -e '/\(fsevent\|kqueue\)/d' ${RUBY_FAKEGEM_GEMSPEC} || die
+}