summaryrefslogtreecommitdiff
path: root/dev-ruby/listen/listen-0.7.3-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ruby/listen/listen-0.7.3-r2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ruby/listen/listen-0.7.3-r2.ebuild')
-rw-r--r--dev-ruby/listen/listen-0.7.3-r2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ruby/listen/listen-0.7.3-r2.ebuild b/dev-ruby/listen/listen-0.7.3-r2.ebuild
new file mode 100644
index 000000000000..68f84e1acbda
--- /dev/null
+++ b/dev-ruby/listen/listen-0.7.3-r2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+USE_RUBY="ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Listens to file modifications and notifies you about the changes"
+HOMEPAGE="https://github.com/guard/listen"
+SRC_URI="https://github.com/guard/listen/archive/v${PV}.tar.gz -> ${P}-git.tgz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~ppc ~ppc64 x86 ~x64-macos"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/rb-inotify-0.9.0"
+
+all_ruby_prepare() {
+ # Avoid a spec with incorrect stubbing.
+ sed -i -e '/loads all the registerd dependencies/,/ end/ s:^:#:' \
+ -e '/return true when dependencies are loaded/,/ end/ s:^:#:' \
+ spec/listen/dependency_manager_spec.rb || die
+}