summaryrefslogtreecommitdiff
path: root/dev-ruby/kramdown
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/kramdown
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/kramdown')
-rw-r--r--dev-ruby/kramdown/Manifest5
-rw-r--r--dev-ruby/kramdown/kramdown-1.14.0.ebuild54
-rw-r--r--dev-ruby/kramdown/kramdown-1.16.2.ebuild54
-rw-r--r--dev-ruby/kramdown/metadata.xml8
4 files changed, 121 insertions, 0 deletions
diff --git a/dev-ruby/kramdown/Manifest b/dev-ruby/kramdown/Manifest
new file mode 100644
index 000000000000..37edf9987b30
--- /dev/null
+++ b/dev-ruby/kramdown/Manifest
@@ -0,0 +1,5 @@
+DIST kramdown-1.14.0.gem 250368 BLAKE2B 78d3638ec58a5c237a9350cad1edabf2d4fa0307013a0ced18f6835c4a8cdd623e4825b06670d5c588147013b191912f93e51e74ab1fe007761c117334f378aa SHA512 bd6295db2fe0d3a7dca936d47f0aaf7f939a86361dfdd3203a52683a9eb11a68075cad7d068cc56a315db3c14e73cf5aebb87531ba3086301a7521c5a86f9905
+DIST kramdown-1.16.2.gem 258048 BLAKE2B a9b35b9e3882cafa32721d0555fa10d806973d4f6e7b617395c00acd3aee43552d74be2442411dc04fec48f7878a7459621ee7848365c165b51959e03a9451da SHA512 da6981969aca283c50b5a34650833c1364afcf74ecc64daba1eed20b198490bf1fdda91096f37574281b50f36713326c367307137446b1fd84a049358a13e4d7
+EBUILD kramdown-1.14.0.ebuild 1441 BLAKE2B a39516ad8947cfa1235e9c9125cb99c74328ba6bcd420862deb6731c2e2905273ecd3a5b7c23a6690a338933a65d0cb43558ffaf91e7cf404833f79262d5f76a SHA512 6d7d9ba85208b89e113b6b6f10983447ff8c08bdc707f8621619b7abdf4b210bd9f7ad45e98516724565120cf3fd9b978f558a42b270a1907ee9fcdf7b61ec84
+EBUILD kramdown-1.16.2.ebuild 1434 BLAKE2B 2c752fcd587701aa01a0f15b540dd88dd335ca1070ed1960f492130efe463459d1028ea1c8cf433ab942e023dc5b052b5ba46e92e4013290b6319689120be42f SHA512 34b638280ad86a46300aedabb7950f9ed669277821bd55dbac0fb5b0aa4c629201ccb7ea609bd741acab412251a9db7cb861981882cf4ad63a3fda04dd09866e
+MISC metadata.xml 251 BLAKE2B e8bf2b70161d425791d65052583fd8be03b19ef3bb2a2cde34605bc93224fea9d8c6a91f0f2d630a00094ef54c0871e210da0e0134f52401bc80cb6b2358c13d SHA512 17d4dbd64468a524311a24ca065537a5b21560388efd282f3fa873e6722f70db6f83e3e5615556450905c29d5df2cf0a0855f9c0b38bf23f0f8112501456d4ea
diff --git a/dev-ruby/kramdown/kramdown-1.14.0.ebuild b/dev-ruby/kramdown/kramdown-1.14.0.ebuild
new file mode 100644
index 000000000000..4c3fd30e71fb
--- /dev/null
+++ b/dev-ruby/kramdown/kramdown-1.14.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_EXTRADOC="README.md AUTHORS CONTRIBUTERS"
+
+RUBY_FAKEGEM_EXTRAINSTALL="data"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Yet-another-markdown-parser but fast, pure Ruby, using strict syntax definition"
+HOMEPAGE="https://kramdown.gettalong.org/"
+
+LICENSE="MIT"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64"
+IUSE="latex"
+
+LATEX_DEPS="latex? ( dev-texlive/texlive-latex dev-texlive/texlive-latexextra )"
+RDEPEND+=" ${LATEX_DEPS}"
+DEPEND+=" test? ( ${LATEX_DEPS} app-text/htmltidy )"
+
+ruby_add_rdepend "dev-ruby/prawn:2
+ >=dev-ruby/prawn-table-0.2.2 =dev-ruby/prawn-table-0.2*
+ >=dev-ruby/rouge-1.8:0
+ >=dev-ruby/itextomml-1.5
+ >=dev-ruby/coderay-1.0.0
+ >=dev-ruby/ritex-1.0
+ >=dev-ruby/stringex-1.5.1"
+
+ruby_add_bdepend "doc? ( dev-ruby/rdoc )
+ test? ( >=dev-ruby/minitest-5.0 )"
+
+all_ruby_prepare() {
+ if ! use latex; then
+ # Remove latex tests. They will fail gracefully when latex isn't
+ # present at all, but not when components are missing (most
+ # notable ucs.sty).
+ sed -i -e '/latex -v/,/^ end/ s:^:#:' test/test_files.rb || die
+ fi
+
+ # Avoid tests requiring node to be installed with mathjaxnode.
+ rm -f test/testcases/span/math/mathjaxnode* \
+ test/testcases/block/15_math/mathjaxnode* || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ doman man/man1/kramdown.1
+}
diff --git a/dev-ruby/kramdown/kramdown-1.16.2.ebuild b/dev-ruby/kramdown/kramdown-1.16.2.ebuild
new file mode 100644
index 000000000000..6a4539198e65
--- /dev/null
+++ b/dev-ruby/kramdown/kramdown-1.16.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby23 ruby24"
+
+RUBY_FAKEGEM_EXTRADOC="README.md AUTHORS CONTRIBUTERS"
+
+RUBY_FAKEGEM_EXTRAINSTALL="data"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Yet-another-markdown-parser but fast, pure Ruby, using strict syntax definition"
+HOMEPAGE="https://kramdown.gettalong.org/"
+
+LICENSE="MIT"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64"
+IUSE="latex"
+
+LATEX_DEPS="latex? ( dev-texlive/texlive-latex dev-texlive/texlive-latexextra )"
+RDEPEND+=" ${LATEX_DEPS}"
+DEPEND+=" test? ( ${LATEX_DEPS} app-text/htmltidy )"
+
+ruby_add_rdepend "dev-ruby/prawn:2
+ >=dev-ruby/prawn-table-0.2.2 =dev-ruby/prawn-table-0.2*
+ >=dev-ruby/rouge-1.8:*
+ >=dev-ruby/itextomml-1.5
+ >=dev-ruby/coderay-1.0.0
+ >=dev-ruby/ritex-1.0
+ >=dev-ruby/stringex-1.5.1"
+
+ruby_add_bdepend "doc? ( dev-ruby/rdoc )
+ test? ( >=dev-ruby/minitest-5.0 )"
+
+all_ruby_prepare() {
+ if ! use latex; then
+ # Remove latex tests. They will fail gracefully when latex isn't
+ # present at all, but not when components are missing (most
+ # notable ucs.sty).
+ sed -i -e '/latex -v/,/^ end/ s:^:#:' test/test_files.rb || die
+ fi
+
+ # Avoid tests requiring node to be installed with mathjaxnode.
+ rm -f test/testcases/span/math/mathjaxnode* \
+ test/testcases/block/15_math/mathjaxnode* || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ doman man/man1/kramdown.1
+}
diff --git a/dev-ruby/kramdown/metadata.xml b/dev-ruby/kramdown/metadata.xml
new file mode 100644
index 000000000000..eb1e47f2edfb
--- /dev/null
+++ b/dev-ruby/kramdown/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+</pkgmetadata>