summaryrefslogtreecommitdiff
path: root/dev-ruby/kramdown
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
commit623ee73d661e5ed8475cb264511f683407d87365 (patch)
tree993eb27c93ec7a2d2d19550300d888fc1fed9e69 /dev-ruby/kramdown
parentceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (diff)
gentoo Easter resync : 12.04.2020
Diffstat (limited to 'dev-ruby/kramdown')
-rw-r--r--dev-ruby/kramdown/Manifest3
-rw-r--r--dev-ruby/kramdown/kramdown-1.17.0-r2.ebuild51
-rw-r--r--dev-ruby/kramdown/kramdown-2.1.0.ebuild51
3 files changed, 105 insertions, 0 deletions
diff --git a/dev-ruby/kramdown/Manifest b/dev-ruby/kramdown/Manifest
index fb43deb1bdfc..06fb8e18c98f 100644
--- a/dev-ruby/kramdown/Manifest
+++ b/dev-ruby/kramdown/Manifest
@@ -1,3 +1,6 @@
DIST kramdown-1.17.0.gem 260608 BLAKE2B 56f0abb2c94ab2de31bcd71940c22610efc8143c434295627513735b5983a369b0d9b36a88477a4e0b14bb23a3d314280702655c854cb7134e29bebc1f276966 SHA512 0f98f4234dec41b53d7f116be1075176c7fcbf21621c6f52a9e5b4055a777b01f1a0a912be81a651e85df022e7bab3ac183ee66cd87abeae092cd1920aceff04
+DIST kramdown-2.1.0.gem 119808 BLAKE2B a5beac52349fb49d315d83391d52574013bd76e084edb25a0b3bc0d813fc5b0dae0799a03bdd20fb500560effc94ad8f262fab9bbb8eef275aaead3405d3a64c SHA512 86a2934218365c71ff4f99591cba3b49ddc5ee60a78fcd7bf1f72e86281cda7bbea3c67b1b7caca6c4b8ca6e5b62d4df25e85089db659c93bd4da4b1c8eada69
+EBUILD kramdown-1.17.0-r2.ebuild 1434 BLAKE2B 4692a13fe9149098e872a6a2acc92917d23c73fda9e5202b9224e607e65dd9ee7d7746b533a9156895bb0bb53e309a81731d9f6015372f09adf3a71f2f592496 SHA512 87956550511622ce241336c838986b00e9604ee13300c9262836828ff4a5126e8e49ef30208c74dcef937ae42dc8d9948c095929015c1d46552c7965c9371fac
EBUILD kramdown-1.17.0.ebuild 1482 BLAKE2B ddeb6e37cd5b1794812386543ce4c05377c69cd45914f24cdeb58c368c2dd62221a289da30825e3cf61e3468d730367d3e7e0c3db0604b978f79047d8631d0a8 SHA512 42ed836f1e1a67dad91925f1c8303771b99f5d933b33b7e56cc5e422e7e27b6dcd0fa7c6b2cb68ac3b3fadc51662dd5d153c51ef81e1f7923ac8ed53fe9e2854
+EBUILD kramdown-2.1.0.ebuild 1262 BLAKE2B a56100681367080769ca5aa3c11a81ad067d1938187cbd5e9649ead5be7aa4f4ccae43fc2c02358dfec30abab6b78561613321defceb27d4ed0d53afbd658221 SHA512 1c29687d4ae5dc44d32ba6fef8fc5ad0e7a0380ccfe05a454914836f6f01730c76e06976c27577f0567084f3f119b3f10a50cb7efc46d6b661d26b1bc9a90e74
MISC metadata.xml 251 BLAKE2B e8bf2b70161d425791d65052583fd8be03b19ef3bb2a2cde34605bc93224fea9d8c6a91f0f2d630a00094ef54c0871e210da0e0134f52401bc80cb6b2358c13d SHA512 17d4dbd64468a524311a24ca065537a5b21560388efd282f3fa873e6722f70db6f83e3e5615556450905c29d5df2cf0a0855f9c0b38bf23f0f8112501456d4ea
diff --git a/dev-ruby/kramdown/kramdown-1.17.0-r2.ebuild b/dev-ruby/kramdown/kramdown-1.17.0-r2.ebuild
new file mode 100644
index 000000000000..d3d8e3605e00
--- /dev/null
+++ b/dev-ruby/kramdown/kramdown-1.17.0-r2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby23 ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_EXTRADOC="README.md AUTHORS CONTRIBUTERS"
+
+RUBY_FAKEGEM_EXTRAINSTALL="data"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Yet-another-markdown-parser but fast, pure Ruby, using strict syntax definition"
+HOMEPAGE="https://kramdown.gettalong.org/"
+
+LICENSE="MIT"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64"
+IUSE="latex"
+
+LATEX_DEPS="latex? ( dev-texlive/texlive-latex dev-texlive/texlive-latexextra )"
+RDEPEND+=" ${LATEX_DEPS}"
+DEPEND+=" test? ( ${LATEX_DEPS} app-text/htmltidy )"
+
+ruby_add_rdepend "dev-ruby/prawn:2
+ >=dev-ruby/prawn-table-0.2.2 =dev-ruby/prawn-table-0.2*
+ >=dev-ruby/rouge-1.8
+ >=dev-ruby/itextomml-1.5
+ >=dev-ruby/coderay-1.0.0
+ >=dev-ruby/ritex-1.0
+ >=dev-ruby/stringex-1.5.1"
+
+ruby_add_bdepend "doc? ( dev-ruby/rdoc )
+ test? ( >=dev-ruby/minitest-5.0 )"
+
+all_ruby_prepare() {
+ if ! use latex; then
+ # Remove latex tests. They will fail gracefully when latex isn't
+ # present at all, but not when components are missing (most
+ # notable ucs.sty).
+ sed -i -e '/latex -v/,/^ end/ s:^:#:' test/test_files.rb || die
+ fi
+
+ # Avoid tests requiring node to be installed with mathjaxnode or
+ # unpackaged katex.
+ rm -f test/testcases/span/math/{katex,mathjaxnode}* \
+ test/testcases/block/15_math/{katex,mathjaxnode}* || die
+}
diff --git a/dev-ruby/kramdown/kramdown-2.1.0.ebuild b/dev-ruby/kramdown/kramdown-2.1.0.ebuild
new file mode 100644
index 000000000000..68d41499af37
--- /dev/null
+++ b/dev-ruby/kramdown/kramdown-2.1.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_EXTRADOC="README.md AUTHORS CONTRIBUTERS"
+
+RUBY_FAKEGEM_EXTRAINSTALL="data"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Yet-another-markdown-parser but fast, pure Ruby, using strict syntax definition"
+HOMEPAGE="https://kramdown.gettalong.org/"
+
+LICENSE="MIT"
+
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64"
+IUSE="latex"
+
+LATEX_DEPS="latex? ( dev-texlive/texlive-latex dev-texlive/texlive-latexextra )"
+RDEPEND+=" ${LATEX_DEPS}"
+DEPEND+=" test? ( ${LATEX_DEPS} app-text/htmltidy )"
+
+ruby_add_rdepend "
+ >=dev-ruby/rouge-1.8
+ >=dev-ruby/stringex-1.5.1
+ !!<dev-ruby/kramdown-1.17.0-r2:0"
+
+ruby_add_bdepend "doc? ( dev-ruby/rdoc )
+ test? ( >=dev-ruby/minitest-5.0 )"
+
+all_ruby_prepare() {
+ if ! use latex; then
+ # Remove latex tests. They will fail gracefully when latex isn't
+ # present at all, but not when components are missing (most
+ # notable ucs.sty).
+ sed -i -e '/latex -v/,/^ end/ s:^:#:' test/test_files.rb || die
+ fi
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:. -e "Dir['test/test_*.rb'].each{|f| require f}" || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ doman man/man1/kramdown.1
+}