summaryrefslogtreecommitdiff
path: root/dev-ruby/jwt/jwt-2.7.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-04 09:13:04 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-04 09:13:04 +0000
commit20169f1085969ebed8224ad70b3c5901602aed28 (patch)
treef7fdb1805284875cb58bf632aa0368b6b0febf9e /dev-ruby/jwt/jwt-2.7.0.ebuild
parent9f132437f051249512ed158be2229f6138332307 (diff)
gentoo auto-resync : 04:02:2023 - 09:13:04
Diffstat (limited to 'dev-ruby/jwt/jwt-2.7.0.ebuild')
-rw-r--r--dev-ruby/jwt/jwt-2.7.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ruby/jwt/jwt-2.7.0.ebuild b/dev-ruby/jwt/jwt-2.7.0.ebuild
new file mode 100644
index 000000000000..4d714d4cccc8
--- /dev/null
+++ b/dev-ruby/jwt/jwt-2.7.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_GEMSPEC="ruby-jwt.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Ruby implementation of JSON Web Token draft 06"
+HOMEPAGE="https://github.com/jwt/ruby-jwt"
+SRC_URI="https://github.com/jwt/ruby-jwt/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RUBY_S="ruby-jwt-${PV}"
+
+ruby_add_bdepend "test? ( dev-ruby/rbnacl )"
+
+all_ruby_prepare() {
+ sed -i -e "/simplecov/ s:^:#:" \
+ -e '/^SimpleCov.start/,/^end/ s:^:#:' \
+ spec/spec_helper.rb || die
+
+ sed -i -e 's/git ls-files -z/find * -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
+}