summaryrefslogtreecommitdiff
path: root/dev-ruby/json
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-25 13:34:50 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-25 13:34:50 +0000
commit479921825a5c44a5fbcd5441f00ee98e54db9bac (patch)
treea40800c43ce47a1158369633f7d432b2bd365743 /dev-ruby/json
parentfa5cba104ab90ce81be0cb7e9992447a10e76013 (diff)
gentoo auto-resync : 25:12:2023 - 13:34:50
Diffstat (limited to 'dev-ruby/json')
-rw-r--r--dev-ruby/json/Manifest2
-rw-r--r--dev-ruby/json/json-2.7.1.ebuild47
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-ruby/json/Manifest b/dev-ruby/json/Manifest
index 503e5bdef98f..547f983f5272 100644
--- a/dev-ruby/json/Manifest
+++ b/dev-ruby/json/Manifest
@@ -1,3 +1,5 @@
DIST json-2.6.3.tar.gz 133077 BLAKE2B f6101f533159fb689b6bf22975137d34a77bd0926c164a9c14f2d5eab982778538ec40551709e8a6470f05e78584a3e5680be740314bb7829b48feb32fb258ae SHA512 1bf9125266d8cdc565deb9e2fe3c884a1fc8d2f3b31caae67a154d0c47e30305074c1c08b49d180dd785c766762b46d3b3ef85919d53388797fcc2f37675317c
+DIST json-2.7.1.tar.gz 125655 BLAKE2B 9921b8dd26123d27b752d3dd633f788437a1aa2003b09ad6d0f43e946362f48a8e5b8dcc70d08f61cc9affa2578750e40c5a78d3bf88e0417af8890100987c79 SHA512 81e7cf51363095088142a7ac15428765f296e9b8c205946abf9ab98ddf7c57aa732c8111e6b0e239606645dfbc24dd40fbe981a52ab2d9fac97c0e3fb08133a0
EBUILD json-2.6.3.ebuild 1391 BLAKE2B df2a6931baf0f5e326101992d3f12a9741136c4f7f7ee8507a9d9e90a6bbd772e01c6dd130dcf736ce0e51b154af543bd2aa058519482193287192da4a69fb70 SHA512 ee4e15ffb2254af61a875532712936c7c5215cc5332b739b5645aefdd0739a0567b22e0da8c1faeacbabc28884d824cf29c2847d7deb8861fea47888d55f7416
+EBUILD json-2.7.1.ebuild 1439 BLAKE2B 37afded6385fa14091f3ac962d47a260ceb60b1bc8888577f3b67cf1af957341da1d6476d028a168fc36ac6ab051f41a117231b3e99af27cc2db2967035c7719 SHA512 f4aa3e127774d451bf1aacb42d539c37ebdeadbf7bf02ca8eadd78d1128c550b972e14029c4556a4389e9c7657317c570fd4d34d99d067a39eabb02a0ba259a7
MISC metadata.xml 337 BLAKE2B 6b424567109cd8947377b5f955a9b32d3c12a25001e8d68cf62ac753264a0d8785f0fc60fc2ffbe5ad4e7a16ebd763add075820e4e559b50f6a230ef2f7a61a5 SHA512 e6900f34ad0c2a8310286eae9942432533dd78a14a04fb5d2551be21437cacc1a2d83b40ec93e885b30626cf49491f7db8a19b6e16009b6931cb0fd0c8ca8d5d
diff --git a/dev-ruby/json/json-2.7.1.ebuild b/dev-ruby/json/json-2.7.1.ebuild
new file mode 100644
index 000000000000..89d650801018
--- /dev/null
+++ b/dev-ruby/json/json-2.7.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGES.md README.md"
+RUBY_FAKEGEM_DOCDIR="doc"
+
+RUBY_FAKEGEM_GEMSPEC="json.gemspec"
+
+RUBY_FAKEGEM_EXTENSIONS=(ext/json/ext/parser/extconf.rb ext/json/ext/generator/extconf.rb)
+RUBY_FAKEGEM_EXTENSION_LIBDIR=lib/json/ext
+
+inherit ruby-fakegem
+
+DESCRIPTION="A JSON implementation as a Ruby extension"
+HOMEPAGE="https://github.com/flori/json"
+SRC_URI="https://github.com/flori/json/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="|| ( BSD-2 Ruby )"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+SLOT="$(ver_cut 1)"
+IUSE=""
+
+RDEPEND="${RDEPEND}"
+DEPEND="${DEPEND}
+ dev-util/ragel"
+
+ruby_add_bdepend "dev-ruby/rake
+ doc? ( dev-ruby/rdoc )
+ test? ( dev-ruby/test-unit:2 )"
+
+all_ruby_prepare() {
+ # Avoid building the extension twice!
+ # And use rdoc instead of sdoc which we don't have packaged
+ # And don't call git to list files. We're using the pregenerated spec anyway.
+ sed -i \
+ -e '/task :test/ s|:compile,||' \
+ -e 's| => :clean||' \
+ -e 's|sdoc|rdoc|' \
+ -e 's|`git ls-files`|""|' \
+ Rakefile || die "rakefile fix failed"
+
+ # Avoid setting gem since it will not be available yet when installing
+ sed -i -e '/gem/ s:^:#:' tests/test_helper.rb || die
+}