summaryrefslogtreecommitdiff
path: root/dev-ruby/jsobfu
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/jsobfu
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/jsobfu')
-rw-r--r--dev-ruby/jsobfu/Manifest5
-rw-r--r--dev-ruby/jsobfu/jsobfu-0.3.0-r1.ebuild32
-rw-r--r--dev-ruby/jsobfu/jsobfu-0.4.2.ebuild37
-rw-r--r--dev-ruby/jsobfu/metadata.xml11
4 files changed, 85 insertions, 0 deletions
diff --git a/dev-ruby/jsobfu/Manifest b/dev-ruby/jsobfu/Manifest
new file mode 100644
index 000000000000..824a32d0fa1e
--- /dev/null
+++ b/dev-ruby/jsobfu/Manifest
@@ -0,0 +1,5 @@
+DIST jsobfu-0.3.0.gem 20992 BLAKE2B 01562d1a2d590d623084d7de48500205a6eb55cf68198219a2f554c71b6213af6957cdf7fcb88f12359eb28317601be322f0dc6f0f5868f26e8423043a67c7da SHA512 64084589066bb8d5c4c775a9a910214306fc1b39ff54582a0cf6485efcca667de57e9e26c02139d1b7baabadf38947464c03bebb72aae65c7be8f993413b6389
+DIST jsobfu-0.4.2.gem 27648 BLAKE2B 280629f104a6aa1cfd4603fff2edf5d2dde5885bf074e39e790e06f03d17a2cf107a6bed61fb2279a3c1e1879e4a74d7faa266561ca10590fb67543ec52e02ec SHA512 84374c8c65691eac6fbdaef78a6faf8a1659474789df2ad0b938cd9101e5b51c69ac5fb157eff3e714decb1402372fe98015a2ef3d77775f0af22fba34f93227
+EBUILD jsobfu-0.3.0-r1.ebuild 709 BLAKE2B 2835cfe4454caafa4424601e966763672bf984d95ff39fceba60ffffa518e0aefae3cef907046e40b7cb5a51af271b988a08557eb9981594170b50897b66bf7a SHA512 adc6d91db2209ba93e28b460f1036235a1dc3d3e50800d918ff166f5265bc1071b7726ddff4afede26a9b5c4cc1e378dff7d85dbbbf26aaf3b8874c53cc99b2a
+EBUILD jsobfu-0.4.2.ebuild 878 BLAKE2B 95fd06544677b6b5cfab57427a6b50e8a8f013a9e71fec6d4ec224bbaeb1e8d688a910dad04420c129035a74d2bec725b7f5e0a8a49a3f459a4acc6dd89dc0db SHA512 286a45ce97605bb5db6a5880671de116313e9f662d9e59f7ca0953d476fe20cec43de45d19759b1c128020ebf70c396cd0b99db6112a275cf7e4b2bc86531135
+MISC metadata.xml 339 BLAKE2B 5d4e7345f4dbb2e4a1957cd23f1e42d0711ab7105ca78a811e66022e94ec8dbdd5a63c1206be9c1df108cb02c7d2c3010286984f16f2e48704950627273a3801 SHA512 58ed2feae94851bc7226f8a4e83cf4a76423a8b8794a0121cefde3dd637829628745bddea8a8c4c9f4917ea37d4470077f0b574ae0d224a8b2ef556eced8b0a7
diff --git a/dev-ruby/jsobfu/jsobfu-0.3.0-r1.ebuild b/dev-ruby/jsobfu/jsobfu-0.3.0-r1.ebuild
new file mode 100644
index 000000000000..a5a638ed0386
--- /dev/null
+++ b/dev-ruby/jsobfu/jsobfu-0.3.0-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Javascript code obfuscator"
+HOMEPAGE="https://github.com/rapid7/jsobfu"
+
+LICENSE="BSD"
+SLOT="${PV}"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+ruby_add_rdepend "!dev-ruby/jsobfu:0
+ >=dev-ruby/rkelly-remix-0.0.6:0"
+
+ruby_add_bdepend "test? ( dev-ruby/execjs )"
+
+all_ruby_prepare() {
+ sed -i -e '/simplecov/ s:^:#:' \
+ -e '/config.\(color\|tty\|formatter\)/ s:^:#:' \
+ spec/spec_helper.rb || die
+
+ sed -i -e '/rkelly-remix/,/name:/ s/=/~>/' ../metadata || die
+}
diff --git a/dev-ruby/jsobfu/jsobfu-0.4.2.ebuild b/dev-ruby/jsobfu/jsobfu-0.4.2.ebuild
new file mode 100644
index 000000000000..436d89702fec
--- /dev/null
+++ b/dev-ruby/jsobfu/jsobfu-0.4.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Javascript code obfuscator"
+HOMEPAGE="https://github.com/rapid7/jsobfu"
+
+LICENSE="BSD"
+#rapid7 gems are slotted so we can have multiple versions installed at once to support multiple versions of metasploit
+SLOT="${PV}"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+ruby_add_rdepend "!dev-ruby/jsobfu:0
+ >=dev-ruby/rkelly-remix-0.0.6:0"
+
+ruby_add_bdepend "test? ( dev-ruby/execjs )"
+
+all_ruby_prepare() {
+ sed -i -e '/simplecov/ s:^:#:' \
+ -e '/config.\(color\|tty\|formatter\)/ s:^:#:' \
+ spec/spec_helper.rb || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ ruby_fakegem_binwrapper jsobfu jsobfu-${PV}
+}
diff --git a/dev-ruby/jsobfu/metadata.xml b/dev-ruby/jsobfu/metadata.xml
new file mode 100644
index 000000000000..f12ab92f0d9f
--- /dev/null
+++ b/dev-ruby/jsobfu/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">rapid7/jsobfu</remote-id>
+ </upstream>
+</pkgmetadata>