summaryrefslogtreecommitdiff
path: root/dev-ruby/jsobfu/jsobfu-0.4.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ruby/jsobfu/jsobfu-0.4.2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ruby/jsobfu/jsobfu-0.4.2.ebuild')
-rw-r--r--dev-ruby/jsobfu/jsobfu-0.4.2.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-ruby/jsobfu/jsobfu-0.4.2.ebuild b/dev-ruby/jsobfu/jsobfu-0.4.2.ebuild
new file mode 100644
index 000000000000..62bd2e8fa7f0
--- /dev/null
+++ b/dev-ruby/jsobfu/jsobfu-0.4.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Javascript code obfuscator"
+HOMEPAGE="https://github.com/rapid7/jsobfu"
+
+LICENSE="BSD"
+#rapid7 gems are slotted so we can have multiple versions installed at once to support multiple versions of metasploit
+SLOT="${PV}"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+ruby_add_rdepend "!dev-ruby/jsobfu:0
+ >=dev-ruby/rkelly-remix-0.0.6:0"
+
+ruby_add_bdepend "test? ( dev-ruby/execjs )"
+
+all_ruby_prepare() {
+ sed -i -e '/simplecov/ s:^:#:' \
+ -e '/config.\(color\|tty\|formatter\)/ s:^:#:' \
+ spec/spec_helper.rb || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ ruby_fakegem_binwrapper jsobfu jsobfu-${PV}
+}