summaryrefslogtreecommitdiff
path: root/dev-ruby/jmespath
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/jmespath
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/jmespath')
-rw-r--r--dev-ruby/jmespath/Manifest5
-rw-r--r--dev-ruby/jmespath/jmespath-1.3.1.ebuild27
-rw-r--r--dev-ruby/jmespath/jmespath-1.4.0.ebuild27
-rw-r--r--dev-ruby/jmespath/metadata.xml11
4 files changed, 70 insertions, 0 deletions
diff --git a/dev-ruby/jmespath/Manifest b/dev-ruby/jmespath/Manifest
new file mode 100644
index 000000000000..818d4674fa2a
--- /dev/null
+++ b/dev-ruby/jmespath/Manifest
@@ -0,0 +1,5 @@
+DIST jmespath-1.3.1.tar.gz 40363 BLAKE2B 516966f9457425658cbe73ae20850e2869d1ac22d000b8220ce58e9eb485ff1fc0f6cf676a2b9571267b69737de1770b2fddeeff88366b8617bf70be7abbd27a SHA512 31f2e4d3137f0f2a837522561860dcab9aa659a51724373509caf9eef9ce7c2bc784ff57e4a527994eb68dfb6f1d2103d31f19e36a31538f0889ef56800c7829
+DIST jmespath-1.4.0.tar.gz 40899 BLAKE2B 45e52f649950b00205af6010084e009a7327600971fdf84e0569498a031e9307876e412a4491fc176724667246fe9f81317a80dd7ff6c44b7e24a135af224e01 SHA512 2b3923a5c853c527ae10ed95da49e3f4888f80ec4eec18fcec2eff16698765e6e875575994ce2fa681977fb5329b122d95cab77fb80ead3548fc26fcbfb33859
+EBUILD jmespath-1.3.1.ebuild 701 BLAKE2B eb65b57231859a5be6072bf6c4acf600ff66466e54ef8038e9a2b2e0ecaa043603c37aadd071b9d0f57d66ec5260ef6b29f7877d0f129be356ccec60fa9762e5 SHA512 f5b1a220a631f05fd4bd6e228782ae787e53961f7e23a03d24572e16b0cbdde5df08626bcfba863e3d91d57e733ec14985faf6c83c1ecad1bb06e3bc6457a5b4
+EBUILD jmespath-1.4.0.ebuild 701 BLAKE2B bc324e28274757e17a58802a2f7a1cc2be50ee528ea28e515240a980bdb4dd0a025f82dfa6742b8b34dd9dee677de14ce34cfd7837817fdd90c68390876f2651 SHA512 0cec66472afd03ae7e2d3a3ba12c696582ccf2c828c139c61a0765b6251d357c36c2de51ea321fa72026a9d10b767e78f1e479bc09bb4af2e9ea62dd2aa82b28
+MISC metadata.xml 346 BLAKE2B 28e720b9aca27cedb4225c5a30166d6b7659ce2f68a87f4827d617fe3a54731b6a84ff78d64859f7de9af7628e117db5907ce7456bbc5e283f654b5a36b946ef SHA512 4ae427bc26ac4b76fca4e2869b64054d7128363b369ac63cff23f19ef0cc5b02ac43c5928ce9e4e56f567d17578d33c32055959d1d22e0dd0671a6b8ba919076
diff --git a/dev-ruby/jmespath/jmespath-1.3.1.ebuild b/dev-ruby/jmespath/jmespath-1.3.1.ebuild
new file mode 100644
index 000000000000..baae00b93309
--- /dev/null
+++ b/dev-ruby/jmespath/jmespath-1.3.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby21 ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Implements JMESPath for Ruby"
+HOMEPAGE="https://github.com/jmespath/jmespath.rb"
+SRC_URI="https://github.com/jmespath/jmespath.rb/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+RUBY_S="${PN}.rb-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="1"
+KEYWORDS="~amd64"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e '/simplecov/I s:^:#:' \
+ spec/{compliance_spec,compliance_without_errors_spec,spec_helper}.rb || die
+ sed -i -e '/bundler/I s:^:#:' spec/spec_helper.rb || die
+}
diff --git a/dev-ruby/jmespath/jmespath-1.4.0.ebuild b/dev-ruby/jmespath/jmespath-1.4.0.ebuild
new file mode 100644
index 000000000000..60b99b077efc
--- /dev/null
+++ b/dev-ruby/jmespath/jmespath-1.4.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby22 ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Implements JMESPath for Ruby"
+HOMEPAGE="https://github.com/jmespath/jmespath.rb"
+SRC_URI="https://github.com/jmespath/jmespath.rb/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+RUBY_S="${PN}.rb-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="1"
+KEYWORDS="~amd64"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e '/simplecov/I s:^:#:' \
+ spec/{compliance_spec,compliance_without_errors_spec,spec_helper}.rb || die
+ sed -i -e '/bundler/I s:^:#:' spec/spec_helper.rb || die
+}
diff --git a/dev-ruby/jmespath/metadata.xml b/dev-ruby/jmespath/metadata.xml
new file mode 100644
index 000000000000..e78875b136cf
--- /dev/null
+++ b/dev-ruby/jmespath/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">jmespath/jmespath.rb</remote-id>
+ </upstream>
+</pkgmetadata>