summaryrefslogtreecommitdiff
path: root/dev-ruby/jmespath
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ruby/jmespath
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ruby/jmespath')
-rw-r--r--dev-ruby/jmespath/Manifest4
-rw-r--r--dev-ruby/jmespath/jmespath-1.3.1.ebuild27
-rw-r--r--dev-ruby/jmespath/metadata.xml11
3 files changed, 42 insertions, 0 deletions
diff --git a/dev-ruby/jmespath/Manifest b/dev-ruby/jmespath/Manifest
new file mode 100644
index 000000000000..a60dacaaa9d5
--- /dev/null
+++ b/dev-ruby/jmespath/Manifest
@@ -0,0 +1,4 @@
+DIST jmespath-1.3.1.tar.gz 40363 SHA256 3555689e777c9c6caad0948bb730a8ecff254dfd5d578d7be7c41f4023b0a648 SHA512 31f2e4d3137f0f2a837522561860dcab9aa659a51724373509caf9eef9ce7c2bc784ff57e4a527994eb68dfb6f1d2103d31f19e36a31538f0889ef56800c7829 WHIRLPOOL efe3afbcf4bc1ed5afc1415f2d6467b389dfc4863b4fcd4a2d1116356e2ab464d03d06fdc0d50613eaadafd2871dcfb6e8f22be89bcd651bb41f91321c7d7f5e
+EBUILD jmespath-1.3.1.ebuild 701 SHA256 b9122af11e9854f0b0c3ccb62b826e32d7e3bfd4f96f2e176538b1bc9130d319 SHA512 f5b1a220a631f05fd4bd6e228782ae787e53961f7e23a03d24572e16b0cbdde5df08626bcfba863e3d91d57e733ec14985faf6c83c1ecad1bb06e3bc6457a5b4 WHIRLPOOL 2f92836921fccafd72625b2c78fc8b6fca574d79c67047bcc2ed2e5f6ad2c7cef153f21b62c2b2dca531bfa5bb5bb78fa8c354ef458f918109c1c199f7ba8358
+MISC ChangeLog 1488 SHA256 19f74b3b7e97436c7b4322b2de6b2dd1a719a64d8b4cfe6178226a172619528f SHA512 680db3f6443291a80d37580660559371d82be2212fa21ab33cfbefafe4379650fe56a21cbb7ec9ef927dabfd2b8ff90fb39866c1e3dbb9b8f6f0ccd649b351fd WHIRLPOOL fc2b66e96c1d9eca44a4f9073abbf94f307191b1240d34e83b6dc8bc9761556622fd5e1828ea4f728c3983ded638cdb094b82ec87f7c97a0349e27d423af2d25
+MISC metadata.xml 346 SHA256 77a5c524aab93b049773d508e8c24ab4b0567cc99fef71dce57aef050cda6570 SHA512 4ae427bc26ac4b76fca4e2869b64054d7128363b369ac63cff23f19ef0cc5b02ac43c5928ce9e4e56f567d17578d33c32055959d1d22e0dd0671a6b8ba919076 WHIRLPOOL 9dbad43debe96e9f4a1e5af2aaf90ba606829ab7c909b9a2c2c183ef1afdb704793362ae4ae3294f932b6bf5318444077d4059544ae97dada27773ecdd7c99d2
diff --git a/dev-ruby/jmespath/jmespath-1.3.1.ebuild b/dev-ruby/jmespath/jmespath-1.3.1.ebuild
new file mode 100644
index 000000000000..baae00b93309
--- /dev/null
+++ b/dev-ruby/jmespath/jmespath-1.3.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby21 ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Implements JMESPath for Ruby"
+HOMEPAGE="https://github.com/jmespath/jmespath.rb"
+SRC_URI="https://github.com/jmespath/jmespath.rb/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+RUBY_S="${PN}.rb-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="1"
+KEYWORDS="~amd64"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e '/simplecov/I s:^:#:' \
+ spec/{compliance_spec,compliance_without_errors_spec,spec_helper}.rb || die
+ sed -i -e '/bundler/I s:^:#:' spec/spec_helper.rb || die
+}
diff --git a/dev-ruby/jmespath/metadata.xml b/dev-ruby/jmespath/metadata.xml
new file mode 100644
index 000000000000..e78875b136cf
--- /dev/null
+++ b/dev-ruby/jmespath/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">jmespath/jmespath.rb</remote-id>
+ </upstream>
+</pkgmetadata>