summaryrefslogtreecommitdiff
path: root/dev-ruby/ipaddr/ipaddr-1.2.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-18 15:36:15 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-18 15:36:15 +0100
commita2f7cdda45fadf1f967379421e8d808b1a503cd3 (patch)
treec02c7db0bb9249243aa73a4098a17e13daaaff21 /dev-ruby/ipaddr/ipaddr-1.2.5.ebuild
parent66611e742171c343d64095516e19737d4753ba61 (diff)
gentoo auto-resync : 18:08:2023 - 15:36:15
Diffstat (limited to 'dev-ruby/ipaddr/ipaddr-1.2.5.ebuild')
-rw-r--r--dev-ruby/ipaddr/ipaddr-1.2.5.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ruby/ipaddr/ipaddr-1.2.5.ebuild b/dev-ruby/ipaddr/ipaddr-1.2.5.ebuild
new file mode 100644
index 000000000000..befd16d48786
--- /dev/null
+++ b/dev-ruby/ipaddr/ipaddr-1.2.5.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_GEMSPEC="ipaddr.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="IPAddr provides a set of methods to manipulate an IPv4 or IPv6 address"
+HOMEPAGE="https://github.com/ruby/ipaddr"
+SRC_URI="https://github.com/ruby/ipaddr/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -e 's/__dir__/"."/' \
+ -e 's/__FILE__/"'${RUBY_FAKEGEM_GEMSPEC}'"/' \
+ -e 's/git ls-files -z/find * -print0/' \
+ -i ${RUBY_FAKEGEM_GEMSPEC} || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:.:test:test/lib -rhelper -e 'Dir["test/**/test_*.rb"].each{|f| require f}' || die
+}