summaryrefslogtreecommitdiff
path: root/dev-ruby/iobuffer/iobuffer-1.1.2-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/iobuffer/iobuffer-1.1.2-r3.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/iobuffer/iobuffer-1.1.2-r3.ebuild')
-rw-r--r--dev-ruby/iobuffer/iobuffer-1.1.2-r3.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-ruby/iobuffer/iobuffer-1.1.2-r3.ebuild b/dev-ruby/iobuffer/iobuffer-1.1.2-r3.ebuild
new file mode 100644
index 000000000000..836cf7725013
--- /dev/null
+++ b/dev-ruby/iobuffer/iobuffer-1.1.2-r3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+USE_RUBY="ruby22 ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGES.md README.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+inherit multilib ruby-fakegem
+
+GITHUB_USER="tarcieri"
+
+DESCRIPTION="IO::Buffer is a byte queue which is intended for non-blocking I/O applications"
+HOMEPAGE="https://github.com/tarcieri/iobuffer"
+SRC_URI="https://github.com/${GITHUB_USER}/iobuffer/tarball/v${PV} -> ${PN}-git-${PV}.tgz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~x86-macos"
+SLOT="0"
+IUSE=""
+
+RUBY_S="${GITHUB_USER}-${PN}-*"
+
+all_ruby_prepare() {
+ rm .rspec lib/.gitignore Gemfile* || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -C ext extconf.rb || die
+ sed -i -e "s/^ldflags = /ldflags = $\(LDFLAGS\) /" ext/Makefile || die
+}
+
+each_ruby_compile() {
+ emake -C ext V=1
+ cp ext/iobuffer_ext$(get_modname) lib/ || die
+}